Blender on Mac keeps crashing on launch

This is the first time trying to run on an Intel based Mac. My old G5 PowerMac kicked the bucket and I used Blender all the time on that thing. Anyways, I can’t get Blender to launch at all on this new iMac.

Running Mac OS X 10.6.8 with 4GB of RAM and a 3.2 GHz Core i3.

Tried running the app from the terminal and get this error:
[new-host:~] ryan% /Applications/Blender\ 2.55/ ; exit;
found bundled python: /Applications/Blender 2.55/
Fatal Python error: Py_Initialize: can’t initialize sys standard streams
Traceback (most recent call last):
File “/System/Library/Frameworks/Python.framework/Versions/2.3/lib/python2.3/encodings/”, line 9, in <module>
File “/System/Library/Frameworks/Python.framework/Versions/2.3/lib/python2.3/”, line 16
except ImportError, why:
SyntaxError: invalid syntax

[Process completed]

Anyone know what the problem is? Maybe I have a bad/out-of-date python installation?


Python comes bundled with blender so you should not need to install any other python unlike older versions.
Ensure you are running a version of blender for intel macs not ppc and use the latest version, 2.62 though 2.63 is coming out imminently

thanks for the reply, but I’ve downloaded the Intel version. I also tried the 32-bit version, just to see what would happen. Same result…instant crash.

I saw a similar post in tracker.
I guess you have an old script in your user-scripts dir which is calling
system python. Sort this out and all should be fine.

You could do a fast test by just “renaming away” your user-scripts folder.