Blender (or, rather, Vista) help, Please!

After a few years of using blender version 2.47, and later 2.49, I eventually decided to switch to a new computer that could take the new, stable version of 2.57. Or that’s what I thought, anyway.
Almost immediately after the creation of my new user, I commenced the download of Blender’s 64-bit installer. Once the thing had been installed, I tried commencing blender by double-clicking on the logo, and instantly, the computer read it as an application in need of being run by another application. In other words, double-clicking on the logo leads directly into a window asking what program you would like to open blender with. That’s bad.
Here’s worse: its not just blender. Internet Explorer, Mozilla Firefox… the computer is treating every program like a file in a mysterious format. It’s so bad, I’ve reported back to my older computer to post this thread.
If anyone knows how to treat this, please respond.
Oh, and a few other things, at the time of my downloading the file, I wasn’t aware that it was a 32-bit computer. I can see it clashing with the aforementioned 64-bit file. Also, I traded out the default location in the program files folder for my personal downloads folder during the install. Lastly, Internet Explorer’s problem became intertwined with some file named “ssvagent.”
Any help would be greatly appreciated.

  1. I’ve never heard of this problem before… Sounds really odd. Have you tried restarting your computer?
  2. 64-bit programs only run on 64-bit computers.

If you are having trouble, uninstall the 64-bit Blender installation, or use Restore Point to go back.

It sounds like trying to install Blender x64 on your x86 (32 bit) computer changed something rather important. :slight_smile: If, like SolarLune said, you go into your Start Menu, and type System Restore in the search bar, you should be able to restore your computer to an earlier point before you installed Blender.

Note: If you have to go back more than a few days, (example, to a Windows Update restore point) you may want to run Windows Update again, as it will uninstall the updates that have been installed since, though it will do it automatically next time it runs…

Thanks for responding. I wish I’d thought of using system restore, though mostly to build confidence in my general computer knowledge, not to save time.
The problem with system restore is that it, like everything else functional, is a program. It, too, opens the “open with” dialog box. If there is any other way to do this, please suggest it.
EDIT: safe mode with command prompt, trying it now…

Sounds like you may have the April Fools virus. I call it that because the same thing happened to my daughter’s computer on April Fools day. All file associations were removed from the registry and the shell command was taken over by the virus itself.

I downloaded all these zip files, which contain REG files that will restore the associations.
http://www.dougknox.com/xp/file_assoc.htm

Oh brother! I didn’t think of the fact that that was a program… I will do some Googling to see if I can find anything similar that happended to others.

Edit: Try downloading the file for .exe’s here:

Go through the steps at the top of the page, and then, once you have restored.exe’s, run a System Restore.

If your Start Menu shortcuts are still broken when you finish the above, go to C:Windows:System32:rstrui.exe (The sys restore program) and run it.

Okay… sorry for the delayed response… safe mode with command prompt was the answer. The most recent restore point predates the creation of my user and the addition of our new internet provider, so that will have to be redone.
In the meantime, when I attempt to download 2.57 again, what steps should I take to prevent the possibility of encountering this problem another time (aside from downloading the wrong version)? Also, what’s the difference between the installer and zip archive?

Other than installing the right version, you shouldn’t have any problems. I don’t know why/how installing Blender 64 bit would have killed your computer, because the system shouldn’t have even been able to run it once you installed it. Chances are, something else may have failed as well. The problem is due to the fact that in your computers registry, (a large library of data) there is a file holding all the file extensions, and what program is used to open them. Somehow, this file got deleted or overwritten. It could be that the 64 bit version of Blender, when trying to install on your 32 bit box, went beserk and trashed it. Who knows…

There really isn’t a difference between the zip files and plain installers. You just have to extract the installer from the zip archive. Once you have it downloaded, right click on the zip file and click extract. This should extract the installer out of the zip file, and into your current folder.

Hope this at least partially answered your questions… (or at least didn’t confuse you more). :smiley:

Cheers!

No, I think I’ve got it. I’ll try again soon. Thanks for the help, everyone! I’ll report back if this problem resurfaces.