Blender Particle Axis for Arrows / Paperplane

Dear all, I am trying to do a simple Particle simulation, where Particles are instanced as arrows and I like the velocity of Particle to change overtime during simulation

I was expecting the arrows to shoot in 45 degree from Emitter and landed on the ground Collission with the face of arrow first (like in Angry Bird), but somewhat the Particles are all keep facing the same direction in a weird angle. Velocity does not seem to follow the force. What did I do wrong?


it seems to works ok here, maybe the dynamic / constant check under rotation…?

Hi Liero, thanks for checking.

I did tick the dynamic/constant option. The axis does not seem to change. I am expecting each particle to rotate following the trajectory.

I uploaded the files:!597&parid=root

hi, setting angular velocity to spin seems to do the trick… you can do some extra fancy rotation there :wink:
ah, and disable dynamic check mentioned before! forgot to tell you…

Liero, Angular Velocity makes those airplanes (Particles) spinning on its X-axis. I am expecting the force to drive the front of Particles. It’s very strange that it does not work as expected. Hmm…

If I turn on Velocity preview, they are all looks correct, but somewhat it does not rotate the Instance.

this worked here: dynamic: off / angular velocity: spin

Hey, horray that setting really does it!

I wonder why … because even with Dynamic ticked and I use any other settings, if I see the Particle simulation as Line and watching the Velocity, it is all seem correct. I almost come to conclusion that Blender Instancer has unsolveable bug. But apparently with that setting above, the Instance duplicates object and the Particle axis now correctly follow the direction of velocity.

Only with that setting above (Dynamic off, Spin on), I got the Instance to follow. I think it’s a weird bug.

Anyhow, it’s all good not, I am getting the result I expected.

Thanks so much Liero! Owe you heaps~

Ok, I should write this down on my blog :slight_smile:

good! I don’t really get all the settings but those are defaults…
and great to see all your explorations and findings written down

The default setting with dynamic off is actually correct for most simulation. I didn’t touch this previously and I knew the orientation should work.

Just recently I have been playing with all the settings, and apparently setting dynamic to ON actually switched off the dynamic orientation. Well… what do you know.