Blender Particle Simulation Not Working! Baking doesn't render particles

I’ve been working on a cool animation and there’s a part where my car blows up a couple of boxes. I followed a quick particle simulation explosion tutorial and did everything exactly the way he did, and my simulation will for some reason not bake. When I bake it, the particles are still the only thing that I see, even in the rendered tab. Even after rendered, it still doesn’t show up. No smoke, no fire. However, the domain is filled with black smoke for whatever reason every frame before the simulation starts and every frame after it ends. (The simulation starts on frame 1977 and lasts until frame 2050) I have searched the internet far and wide and haven’t found anybody with a solution for this problem. I also have tried to fix this for 3 days now, and cannot seem to fix it. Perhaps it’s a bug? I’m really open to suggestions. I have a link to the YouTube tutorial Create Explosions in Blender - YouTube and also some pictures showing the issue. Also, I’m using Eevee render engine.

Here’s another picture of the domain filled with smoke before the explosion.

Also, 1 last thing. I tried taking only the emitter and the domain into a new scene to see if it would work, but I had no luck.