Blender People not working

I am using bleder 2.34 and Python 2.3.3 I have instaled Mysql 4.0 and the mysql-python that came in the download I get Import mysql highlighted
and an import error saying that there is no such module Please help! :-?

have you updated your system paths in blender, because you need to add a flag to python in order to get the path to python 2.3.

I’ve set the python paths if thats what you mean

Have you run other Python scripts successfully with this installation?

I have run the fiber generator script by Ripsting with no problems.


What’s the problem?

Sorry - haven’t been on elYsiun in days. Having a life and all - didn’t mean to be rude.

Can you please post the full text of the error message you get? Also, the exact version numbers of Python, MySQL, and MySQL-Python. I’ll see if I can duplicate it.

Also, before you do that, did you install the MySQL-Python module after the Python and MySQL installations? Doing it in the wrong order could potentially break things as well.

Python 2.3.4 mySQL 4.0 mySQL-Python 0.9.2
I installed python then mySQL then mySQL-python

Error message:

Traceback <most recent call last>:
File “”, line 17, in ?
ImportError no module named mySQLdb

Did you have a previous installation of Python (2.2 or such), which the Python-path may be pointing to instead of the 2.3.4 install?

Yes I have 2.0.1 and 2.2.3 how do I check if blender is pointing to the wrong one? and how do I fix it if it is? (I’m on winxp home edition)

make a script:

import sys
print sys.path

if the path is wrong, there’s a sticky thread in this forum called “how to set pythonpath”

I managed to get python instaled properly and that fixed my problem but now it gets an error with the line “CheckDB.CheckDB()”

look “Jedi Dawn”:
Blender People is a very complex script, since it uses mysql. maybe you should wait for a full release or something? I had my problems with CheckDB too. since I didnt try this for some time now I cant tell you a lot about it. The CheckDB fucntion checks if the tables required for Blender ppl already exist or not. so change to the script CheckDB, execute it and check your console… my problem was the link between the 2 scripts.

Actually, this is me being lazy (sort of). Look back in this very thread and you’ll see a couple of people with CheckDB problems. The latest installer of MySQL has a different default user permissions setup than when the last version of BP was released. Changing these permissions in MySQL will fix the problem.

If you still can’t get it going, check this thread for one of the users who had this problem then fixed it for a better description.

I’ve said a number of times that I’ll fix this in the BP release, but I’m trying very hard not to divert my very little spare time from pinbone and animation features in the source code.

What should I change?

Umm… I think (because my system hasn’t run into this problem, I’m just speculating) that you need to use the MySQL control panel to enable connections from any user on the local host ( or localhost). BP just connects to the localhost, assuming that MySQL will receive the connection.

Okay. They did change the default settings for a MySQL install. It used to allow default access for any user on the local machine. Now, you have to enable it. Here’s how:

  1. Get MySQL Control Center. Accessible here:

  2. Install and run it.

  3. Right click on the server icon on the left side of the window. Select “Edit” from the pop-up menu.

  4. Under “username” in the edit screen, type “root”, then hit the “Apply” button.

  5. Expand the “User Administration” item.

  6. double-click “@localhost

  7. Put checks beside “All Priveleges”, as well as any databases that appear on the right panel. Hit “Apply”, then “Close”

Try running BlenderPeople now.

This is really cumbersome, and I’m going to have to come up with a better way to do this, without the user having to jump through so many hoops.

*** Easier alternative:

  1. Go to line 5 of Change (host=‘’) to (host=‘’, user=‘root’)

  2. Go to line 24 of Add the same parameter (user=‘root’) after db=‘adActors’

Most likely that’s the fix that will be in the next release.

I sure hope this works.

  • another bug!
    the “checkdb” script generates the tables correctly after the modification harkyman mentioned. exept from 1 thing!

checkdb generates a table tbl.Groundtree, but it should be tbl.GroundTree. so either modificate checkdb or your database.

so, line42 from:

		SQL='CREATE TABLE tblGroundtree (ID int(11)... etc... etc...


		SQL='CREATE TABLE tblGroundTree (ID int(11)... etc... etc...

maybe it works on windows since it’s less case sensitive… anyways…

#rendering a sample video :slight_smile: I love this… now that it works (no crashes at all so far)… awesome…


It works!