Blender performance in Windows Vista


I have a GeForce 6600 GT card with 128 MB and I installed Vista recently.

Blender’s performance is fine(but slower than in XP) if Aero is enabled.

But if I disable Aero, Blender becomes unusable(low framerate). Other OpenGL applications work fine, and the renderer reported by glewinfo and sysinfo script from blender is GeForce 6600 GT (not the windows driver).

It is really strange that performance is poor with Aero disabled since I’d expect otherwise …

Any ideas on how to solve this problem ?

upgrade to XP :slight_smile: yes, or ubunutu. :wink: did I mess anyone? oh yes, get a mac, sorry. :wink:

Seriously, look at blender benchmarks page. Blender under XP is faster than Vista.

Give it the three finger salute, go to task manager, processes, right click on blender.exe and set priority to high. Or go with 64 bit vista. or use the SSE2 build if your processor supports it, which if your running the vista hog, you probably have.

Uninstall Vista. I’ve got a new laptop with an NVidea card and Vista, while I was modeling I noticed that in solid draw mode I couldn’t select vertices correctly: I’d click on a vertex, and a vertex somewhere else in the mesh would light up. In wire frame draw mode the selection worked correctly. Having to switch back and forth from solid to wire frame is a royal pain in the where ever. I wonder how many more little surprises Vista has in store for the hard working blenderer?

I,m sitcking wtih Vista 32 Bit but using the Blender SSE2 build. My render time on the benchmark test has dropped from 1:40 to 1:15. On an HD render I am doing now, it has gone from 4:45 per frame to 3:27 per frame, a 35% speed improvement. 630 frames (only) takes 36 hours to render, not two days. Yea!!!

I had that same problem, but it wasn’t with Vista because it happened on normal XP. I don’t know what the problem is, but I think I fixed it by completely deleting the directory and then re-installing.

I’ve noticed the same thing. i think vista does some weird things with hardware accelerated video in non-aero vista to make aero seem more desirable. videos in non aero are not smooth scaled, but in aero they are. and the framerate dramatically drops when you turn off aero. i wouldn’t be surprised if it was some idea cooked up by the marketing department, but it is strange.

make certain you set your thread at 2 or 4 to render - make test to see the best value
if you have dual core processor
you can turn off Aero see help file

i never tried the task manager prioritie - but i will
with alll the tasks done by vista i’m not certain that it is good for the other things around in Vista