Blender + Radeon ATi = Slooow?

Got a brand-new PC and Blender is VERY slow. Slowness is apparent as soon as I launch Blender. Rolling mouse over buttons, I can watch the words being re-drawn. Spacebar menu even slower. Rendering default cube scene takes 15+ seconds!

I’ve seen forum posts about downloading a .dll and custom compiles of older Blender versions. But I’m not sure which path to follow.

QUESTION:
EXACTLY what should I do to fix this problem? If .dll related, where do I get the file(s) and what do I do with them? Must Blender or Win-XP Pro be re-configured to point to the new files? I am not a hardware jockey so please speak slowly :slight_smile:

Video card: “PowerSpec Certified Radeon 7000 -Graphics by ATI” Card details: Bus type: AGP 2X/4X, 32MB DDR video memory, 64-bit memory interface, DX 7.0/8.0 Direct X support, Open GL support, VGA, DVI, Hyperz technology, Video Immersion I technology, and Hydravision.
Win-XP Pro, Service Pack 2
AMD Athlon XP 2400+, Soyo motherboard
Blender 2.34 and 2.32 behave the same.
Reducing the resolution helps a little but it’s still unuseably slow.

TIA for any help!
-potus98

did you mean this thread?
https://blenderartists.org/forum/viewtopic.php?t=17626&postdays=0&postorder=asc&start=225

did you mean this thread?
https://blenderartists.org/forum/viewtopic.php?t=17626&postdays=0&postorder=asc&start=225

Sort-of, but that thread doesn’t work. I followed to http://www.blender.org/modules.php?op=modload&name=phpBB2&file=viewtopic&t=3789
and downloaded the custom compiled files in http://download.blender.org/demo/test/blender-ati-31May04.zip. Unzipped the files and dropped them into my Blender folder -overwriting the previous versions.

No performance improvement. UI still slooow.

BTW: While checking out the ATI site for the “Catalyst” software, it does not mention support for the Radeon 7000.

Other suggestions?
TIA!
-potus98

get a new video card, the 7000 is antique

[preferably an nvidia, a geforce 2 even is plenty for most blender work]

the other problems with ati cards was that blender would initally run quickly, but with use would get slower and slower and less and less responsive. this problem requires both a blender version 2.25 to 2.32 or 2.33, and a ati catalyst driver version 3.6 or 3.7 and later [I haven’t tested 4.8,4.9,or 4.10 with the bug though]. 2.32, 2.33, or 2.34 introduced a fix, but I think it makes box selection and stuff unresponsive

the other problem that people report on ati cards, as well as others, is that the menus will draw and erase painfully slow. The ati cards people report this happening on seem to work fine in other configuations, but I don’t have exact records and cannot say that for sure.

in general the solutions to graphic problems are:
different color depth
newer video drivers

and that’s pretty much it, if those fail you should probably get a newer video card.

wal mart sells a nvidia 5200 ultra 256mb for $128. nVidia runs blender better. Dont forget to upgrade drivers

get a new video card, the 7000 is antique

Oh.

My new (non-ATI) card seems MUCH better. I picked up an nVidia eVGA.com e-GeForce 4 MX 4000 w/ 128 MB DDR AGP. CD installer suggested keeping my current drivers. I guess Win-XP Pro SP-2 already had the latest drivers.

Any tuning or tweaking suggestions to make Blender leverage the video card better than default settings?

-potus98

get nvidia’s drivers, the xp ones aren’t that great and don’t offer hardware acceleration

also, try to make sure your ati drivers are completly gone first, they should be in the add remove programs in the control panel.

oh, and make sure you reboot