Blender radiosity bugs strike again?


(DAK) #1

I am not sure what is going on. Before my 3 layers worked fine. Now, if I add the first layer, it prevents some objects from being rendered after a radiosity solution. When I combine the mesh I see all the objects there, but when I hit render I only see the shadow of some of my objects in one of the layers. Yet all the other objects render fine.
What the…


(BgDM) #2

Happens to me sometimes as well. I think it is a bug. Buty I could be wrong.

BgDM


(DAK) #3

Alright I think this pretty much confirms it. Trying to get good lighting in blender is pointless. Even the radiosity solution is buggy as hell. I have to now abandom my project and start anew. I think i’ll give lightwave a try, seems to be pretty decent. I just feel bad I wasted my time on blender radiosity for nothing.


(lycanth) #4

There’s a limit to the number of materials the radiosity system will accept (I think it was 16). The work-around is to combine objects of the same material together before running the radiosity pass. If you absolutely can’t use less materials, you can try setting up your scene with a single material and then adding materials after doing radiosity.

Yeah, it’s not ideal, but that’s what we’re all here to fix once the source is opened.


(DAK) #5

I do not think this is a material problem. It seems the more objects I add, the more (others) just disapear. Like it’s in some kind of equilibrium. I"ve already started a new project twice, and running into the same error. I just dont get how the objects are all converted in the mesh, I see them, but the damn render causes some to disapear!
I am not even adding a material to the new objects I add.


(lycanth) #6

How many objects do you have in the scene? I had the same problem once with several separate objects that were using the same material (I think each is then considered to be a separate radiosity material, so you hit the limit quicker than you might expect) - but the problem disappeared when I joined them with Ctrl-J. Also, objects with no material end up getting a default radiosity material anyway. So maybe try joining those extra cubes to something else in the scene, and assigning the same material to them.