Blender RC3 is slow on Ubuntu V6? (How can this be?)

I got Ubuntu to work on my Acer travelmate C300 tablet pc - it was very easy and even the pen works. I ran Bender RC3 with a large model. The realtime render is faster in Windows XP than Ubuntu but I can’t believe that. Also, it appears that the virtual memory is handled better in Windows XP because it took 40 minutes to render a scene in Ubuntu but only 9 minutes in windows XP ( I assume its because windows paged less). Is it possible that I don’t have openGL setup right? Is it also possible that I don’t have the virtual memory set correctly in Ubuntu? Help would be appreciated.

Linux uses memory way more efficiently than XP, so that’s not it.

Type in ‘glxinfo’ in a terminal and see if direct rendering is on. It will say so towards the beginning of the list. If not, then no OpenGL is not working properly.


I made a typo before. The ‘glxinfo’ is correct (without quotes, of course). You should see something like this at the top of the list:

name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: NVIDIA Corporation

i am new to ubuntu
and i noticed a problem in linux about the performance
i used to test my computer with this file

in windows ( using optimized version )
this is my times
02.45.97 Thread
03.35.20 No thread

in linux with optimized version too
i have this times
04.00.91 thread
04.54.74 no thread

so i compiled my own version on ubuntu ( it’s optemized too )
and i have this numbers
03.12.95 thread
04.08.20 no thread

it’s beter numbers than the optimized build that i downloaded from net
but i can’t get close to windows time

i have
p4 3 GHZ 2 mega cash
1 Giga ram DDR2

(btw) i tried ‘glxinfo’ and it give me
direct rendering: Yes

Thanks for posting that test.

On my dual boot Acer travelmate C300 dual boot laptop (512 MB RAM and 1.6 GHz Centrino processor) I get 3 min 43 sec on Windows XP and 5min 43 sec on Ubuntu. I ran glxinfo in a terminal window and it says “direct rendering: yes”.

Anyone have any ideas?

I noticed that your computer has onboard graphics card with shared memory, I guess shared memory means that it uses ram for graphics also, are you sure that 512mb is enough? Default desktop on Ubuntu can use quite a lot memory.

To save memory you can change metacity to some lightweight windowmanager like openbox, you should also use kernel thats right for your processor, on my duron changing from kernel-i386 to kernel-k7 gives big speed boost.

Lots of things seem to affect rendering speed, my best time in blender benchmark is 0.04.08 with optimized blender 2.42a and ubuntu 6.06. Current time with very well optimized gentoo and unoptimized 2.43 final is 0.06.06.

You can check memory usage with commands free, top and ps. This is also useful:

Any proof? Like benchmarks? I bet not…
Ubuntu 6.10 (x86) has only 386 and generic kernel images, because the differences of optimized kernels were insignifficant, the kernel has runtime optimizations for important parts these days…IMHO it’s mostly a placebo-effect. :wink:

What kind of builds are we talking about anyway? There’s all kind of builds around, from plain MSVC7.1 to tweaked-to-stability-limit-and-beyond™ ICC builds for Windows for example…

It seems that you are right, but at that time when I changed from i386 to k7 I did some other cleanup too, it was self compiled kernel.
Blenderbuilds has sse, 3dnow, etc optimized builds.

I installed the KDE desktop on Ubuntu with this command:
apt-get install kubuntu-desktop

and then ran blender v42r3 with the test.blend file mentioned above and still get 5 minutes 43 seconds. I checked memory usage during the render and it was only 270 Megs max. Anybody have any ideas what’s wrong?

Rendering is a cpu intensive process that depends essentially on cpu and memory. Your graphics card will have little effect on this.

Render times under Linux and Windows should be roughly comparable - certainly not the 40:9 difference you are seeing.

Something is definitely funky here. Have you used any of the system monitor tools to explore what is going on? Have you asked on the ubuntu forums?

I’ve been trying out Blender on Puppy Linux, but found that Blender was very slow.
I’ve found out the the X process was using ~70% of the CPU.
I’m running it with XORG.

Anyone, got a solution to this problem?

Of course it makes no difference to render time whether you use GNOME or KDE, and KDE is not exactly known to be more memory efficient than GNOME either :wink:

I just did a test with my notebook too, and the official linux build really is far from good performing…so i compiled myself with gcc 4.0 and adding the flags -march=pentium-m and -mfpmath=sse which resulted in almost 50% more performance!?
(that’s 6:09 vs. 4:08 on an 1.5GHz Centrino, unfortunately all windows builds refuse to work for me, so i can’t compare right now)

If compiling wasn’t that slow on the notebook i’d have tried a couple more flags, like only using -march or even plain gcc 4.0…seems the official release is still done with gcc 3.3…

I am trying to get the sse2 optimized build from to run on my Ubuntu. I don’t know how to compile blender on linux and all the ffmpg libraries are difficult to deal with. I installed python 2.5 but there is an illegal operation when I try to run blender. This is hard.

On my P4 I have to set the threads button in the render panel to 2 (set xparts 4, yparts 4) or I only use half the cpu power.


Stay away from Python 2.5 until your distro upgrades. Python is a dependency of many programs, including parts of KDE, and you’re going to end up breaking a lot of stuff.

I just re-read this thread, and I have a question. Are you comparing XP and Ubuntu on the same machine?

Are you comparing XP and Ubuntu on the same machine?

Yes, I have setup my tablet PC with dual boot so I do compare it on the same machine.

Try taking the graphics card and Xorg out of the picture by doing a render from the command line for example the test.blend in /tmp:

blender -b /tmp/test.blend -f 1 -t 2

That will render frame 1 with two threads. While it’s running use the command top, what processes seem to be using the most cpu?

Blender from source is not too bad to setup on linux. I have suse so I’m not sure what packages you have but here is what I had to add, just google the package to find the home for the source.

openal-0.0.8, OpenEXR-1.2.2, ffmpeg snap shot of source, scons-0.96.1.

Most of those packages it’s just ./configure, make, make install.

Then edit in blender-2.43/config/ and change the Python 2.4 to 2.5. You can also add your optmizations to the CFLAGS and CXXFLAGS line, I added -mtune=prescott to get sse.

You should be ready from the blender-2.43 source location to run scons and have it do the build.

If the build complains about missing headers see if the devel packages are in your distro, if not find the source package and install it.

99.3% blender
0.7% xorg
I will now try the scons compile you sugest.