Blender: red Mesh bug while "occlude background geometry"

Dear Blender Artists!

I have a problem with my Blender. When I press any buttons or hold my cursor on buttons in Edit mode while “occlude background geometry” is activated, the screen turns partically black, other not-selected objects dissapear and the mesh turns red (view attached Files for more details). However, single vertices cant be selected correctly, too.

My system:

2x 2800MHz (DualCore)

2048 MB (Registered DDR SDRAM)

NVIDIA GeForce 8800 GT (1024 MB)

Does anybody know any solution? Is it a new bug, which should be reported to blender.org?
Greetings from Germany,
Hawaii.Hai

P.s.: I haven’t found the same problem in the FAQ or Engine Support forum, but maybe I have used wrong keywords. In that case im sorry.

Attachments


its a graphics thing, i got the same problem with one of my vista computers

i solved it by opening up limewire, which changes some graphics settings and then makes it work, i dunno if that would work for you though lol

sorry, i dont understand “to open up limewire”…
Limewire is a p2p-program, isnt it? where is the connection to blender or even graphic troubles?
In addition to that, i dont even use any p2p-programs.
thx

Hawaii.Hai

This is an nvidia driver option that isnt correct but works ok in many cases.
on linux the option is called “noflip” not sure where to access that from windows.

I get the same bug on both my PC and my laptop, and my laptop doesn’t have an nvidia graphics card. Maybe a Vista thing?

Either way, worth reporting - I spoke to some friends who use Blender, and a couple of them have encountered it too, so it seems fairly widespread.

Have you found any kind of workaround? It’s really disrupting my current project.

A forum search brings up this thread with some suggestions.
http://blenderartists.org/forum/showthread.php?t=139614&highlight=red+mesh+nvidia
Richard

I’ve had that problem when anti aliasing is on, and any menu that overlaps the 3D window is open(so many of them)…I found by making sure antialiasing is off, the problem would go away…this may or may not help you.

I’ve taught Blender classes for about 3 years now, and I’d say I have this issue with about 3 out of every 10 students. They generally work exclusively with laptops.

Probably the integrated graphics that most laptops have that gives the graphic issues.

Richard

Hi, I have been using Blender for about a month now, and I have just run into this problem now. Could it be a heat issue? I have a Dell laptop with integrated Intel graphics card. I just thought it was strange that I havent run into the problem before…
Thanks

FWIW I think that I traced this bug down to directX8. Turns out that directX8 support by directX 9 or 10 is incomplete and doesn’t reset the card correctly. Running anything that utilizes directX8 prior to using blender can bring this on. It seems to be an nVidia driver bug that is common to 7800-9800 cards. I haven’t heard of it in newer cards. Installing the latest drivers fixed it for me (on 8800x and 9600mt cards)