Blender render engine black spots

Hi guys,that’s my first post here (i’m luigi by the way,i’m italian :wink: ).
I wish you to ask help about a problem occurring when i try to render with the inbuilt blender render engine:It gives me these black spots and dots on the model,thing that doesn’t happen with the cycles engine as you can see by the pic i added.What should i do?


You have vverlapping faces.
Remove any duplicate objects and remove double vertices (select all vertices and W / remove doubles)
Check your modifiers settings for any that may create geometry such the mirror modifier

Happens for example when you export a model from sketchup collada and import it in blender. In Sketchup every face can have a front and a back material, so it exports two faces for each face. If all unnecessary faces share the same material, you can easily select and delete them, if not it is some manual work.

[QUOTE=Richard Marklew;2687520]You have vverlapping faces.
Remove any duplicate objects and remove double vertices (select all vertices and W / remove doubles)
Check your modifiers settings for any that may create geometry such the mirror modifier

well the vertical slats on the dalek that you see on the shoulders are taken from another model (models are not mine) and put on this that didn’t have them (even if in the second i mistakenly deleted them),and if i’m not wrong the dome too (i transferred the parts from other layers and put them in place), does this mean i cannot do it??
for 2nd clemens:the models are blend files,are not imported

does this mean i cannot do it??
You can do anything you want, just check your model for overlapping faces / duplicate vertices. Either do it yourself or supply a link to your blend file

i tryed to delete duplicate vertices but it says “0 vertices removed”

Upload your blend file to http://www.pasteall.org/blend/ and tell us the download link

here’s the one http://www.pasteall.org/blend/30462

i tryed to delete duplicate vertices but it says “0 vertices removed”

Have you tried to increase Merge Distance value on T panel bottom?

Sometimes it’s possible to use L in face select mode to get one layer of faces. Press H to see if there are other faces below.

I did it,thank you for the advices :slight_smile: