Blender Render scene looks different in viewport vs. Video Sequence Editor

I’m lining up scenes I’m working on in the VSE. This is for animatics, and I’m trying out using Blender Render to use the “Mist” feature to quickly add depth to the shots.

Things look okay for the most part, but I’m finding there’s a huge discrepancy between what I see in the scene viewport vs. what I see in VSE.

Here’s an example. The scene in Blender Render viewport:

And here’s what it looks like in VSE:

I think this is due to the Shading options not showing up VSE.

I’m using Backface Culling to create the view port outlines (using the solidify modifier), and Ambient Occlusion for obvious reasons.

Does anybody know what to do here?

Bumping this for knowledge. Or maybe this is simply a bug.

Anyways, an update with a sample file: BI Viewport VSE DIff.blend (653.6 KB)

The upper half is VSE, the lower half is BI view port. On the right are the Solidify Modifier and the two materials I created on Suzanne (For the view port outline effect. One is literally the default material, the other, only change is color to black).
If I turn off the Backface Culling, DoF, and Ambient Occlusion in the view port, the result looks the same. But if I turn them on, the VSE doesn’t reflect the changes.

In the vse view port open the n panel and change to look dev or rendered. Solid and wireframe seem to display buggy

edit: maybe your problem might be a diff one, not sure

Ah, I should clarify that this is 2.79, not 2.8.

2.8 doesn’t seem to have the problem of visual discrepancy, but it does lag horribly.

I have tried changing the “Scene Preview/Render” options before, but to no avail. =/

Your Backface Culling is a viewport only feature that does not apply to rendering, so you’re seeing the black back faces in the VSE, F12, and viewport Rendered display mode.

You can do the equivalent operation at render time using nodes according to this:

Right, I’m aware. But I’m just doing an animatic so the final output is fine as view port only.

The issue here is that the “Material” shading mode in the view port is different in the VSE. Right now, my assumption is that, for whatever reason, the “Shading” options (Backface Culling, Depth of Field, Ambient Occlusion) are not showing up.