Blender renders fine in UI, but file output is unfinished

When rendering stuff with blender, it shows up normally in UI, but when outputting to file it doesn’t render background color at all.

Instead, it simply replaces the background with transparency or white, and output will look SHIT. So what’s the problem?

Have you selected sky in the render settings ?

Richard

Yes. As I wrote, it shows up normally in UI view. But file output does not have sky/background color blend.

EDIT: It works fine if I render it as animation. But if I render a still image it doesn’t output to file without nodes and no background.

Look on the Render Format panel and check if RGB is enabled. If you have it set to RGBA it will save the sky as alpha if the file format supports an alpha channel.

It is RGB, no background when rendering a still. But it’s “Blender 2.48 (sub 1) Build”, as blender --version says.

If you are outputting the render to the UV image editor. Make sure you haven’t selected the “Draws Image with Alpha” button to the right side of the image editor header.

Richard