Blender renders so fast that it crashes!

I am on V 3.0.1 drawing a scene to png.
It’s a 10fps animation, of a graphical bar at the bottom of another project. The render is eevee, the scene is very simple, a few animated objects and a few objects with image textures on. The image resolution is 1920 x 30 (yes only 30pix high).

This is probably a very uncommon problem, but how do i SLOW DOWN the render? It seems to crash after about 1000 frames, but there are 468,000 frames of animation to output (e.g 12 hours). I can only imagine it is rendering so fast that problems are ocurring.

There’s no way you have enough RAM for 468,000 frames. No one does. It’s crashing because it’s out of memory, not because of render speed

Incorrect, I am afraid, I am watching the ram usage (in MSI afterburner) and it’s not going above 7gb usage out of 16.

Hum, the output should be stored on disk while writing. being image sequence or video.
I doubt that everything is kept into ram, only the current frame.

But yeah, at least it’s possible to write to a image sequence and encode that with a dedicated app.
That way it’s also possible to resume rendering when it crashes…

Does it goes over 1000 ?

If you want to make the render slower, you can add some samples, and maybe add some filter in the compositor like several gaussian blur, glare, ect… then alpha over you render on top of that.

It could be a bug , like it’s too fast as you said, but I doubt it…

No the program quits running when it’s around 350mb usage. It’s weird and seems to vary between rendering 1000 frames and 5000 frames before it quits.

have you tried rendering to an image sequence ?

1 Like

You mean a movie sequence? By default it goes to a image sequence.

Crashes just the same with a movie sequence.

Processes aren’t allowed to use all of the system RAM, every process is capped at a fraction. Blender will never use anywhere near the 16 GB you have, I’m pretty sure each process caps at 50%, so you could use at max 8 GB for Blender. Given that you’re seeing 7GB usage, you’re definitely close to your RAM limit, and I would imagine you’re using more than is being reported for system processes

What i mean is I am seeing 7gb usage from ALL programs on the entire system, not from blender itself. Blender is using about 320-350mb until it crashes.

Ok if you tried both that at least answer the question.
You can try to make a default scene with your rendersettings, and see if that lead to the same issue.
Then post that .blend and I can try to render it and see if that lead to the same crash.

Blender is documented as rapidly accumulating RAM and VRAM on large animations -, for instance, although there’s many more examples you can find - even if you have enough RAM for 500k frames, do you have enough VRAM?

Ok so a weird thing happened…

It was rendering away at high speed, probably a crash would be incoming. I tried to change the “render display window” in the corner, to something else, such as the text editor. Then I noticed at a certain point on the main screen’s timeline, the frame marker stopped advancing, like it had crashed, but the render progress bar was stopped at 99%.

Blender would then let me change stuff in the scene, but I could not re-render, and when I tried to revert the scene to try reload and maybe the stuck render would stopped, it then had the “program has stopped responding” freeze up. Dunno if any of that helps?

the default scene without the cube, and as much as sample you use, that should be as fast, even faster than your render, it can help to narrow down the issue.

That mean blender didn’t stop rendering, you can change things in the scene while it render but that’s a bad idea… but yet hard to tell what’s going on…

Nah, its not that, just tested it, and again it quit after approx 1000 frames, but the vram usage was 1022 out of 8192 at the point that it did.

I tried a default cube scene with eevee and same frame and sample size. It wasnt rendering as fast, and didnt crash till about 11,000 frames rendered, but it still did crash.

There is one other thing maybe worth mentioning now that I think of it. The scene uses the “LeoMoon” text counter addon which updates an text objects per-frame with a value for a count up or count down.

However, I have completely removed all text objects that had that on them from the scene, the issue still presents.

I have attached the file.
Please note that this is the version which has the dynamic text objects in, so to see the correct results, you would need leomoon version 1.3.6, on blender 3.0.1. The plugin can be downloaded at:
12_HR_GAMEBAR.blend (3.8 MB)

I’ve seen several posts about blender ceasing to render, resulting in a crash.
Is there a memory leak?
I’ve had a scene or two crash like that but without rhyme or reason.
Have you tried to render on the command line?

1 Like

Not really sure how to do it. It says on the help docs to put in a command (

but put in a command WHERE?

Ok - I have figured out it needs to be in a ms-dos batch file, and have run it.

UPDATE: So far it has done 130,000 frames (via command line) without any crash.

Ok ! So if that still crash with the default scene then it’s not related to the addon or your scene.
At least it’s best to try without it to narrow down the issue.
I’ve launched the render with blender 3.1 on linux

I am rendering the actual original file with the problem. It has done now almost 50,000 frames without incident or crash via the command line. So, barring a technically accurate description, it seems that with the program open, it really IS rendering too fast for the full program to cope with, somehow.