Blender Running UNBELIEVABLY SLOW

My computer is about two months old, it’s a high performance machine with 4 cores, the latest, and best Bitdefender, and a driver updater. I set it for GPU compute, and set everything I could find to optimal settings according to what I found online. I checked the graphics card driver , and it’s up to date.

Yet ever since I updated to the latest stable release it started to run terribly, whilke every other program runs fine, even at the same time. I’ve even tried multiple times to return to 2.64, clean reboot, and now even 2.64 runs like garbage. So I went back to 2.65, same thing.

We’re talking click ANYTHING, long pause (30 seconds to one minute) then a message saying “not responding” followed by 3, 5 or 10 minutes of waiting for a response, then click on anything else and the whole cycle starts AGAIN!!

I would greatly appreciate help fixing this, Blender has become completely unusable on my computer:eek:

Tim

is this while rendering?
what gpu do you have you didn’t give us much detail

A good way to check if this is graphics card related or not is to test running blender with a software-only opengl implementation.
On XP you could fallback to VESA drivers to do this, not sure about newer windows versions.

This should be in technical support firstly.

Secondly, do you have force-enabled antialiasing for OpenGL? That’s one of the major issue-causers f*up Blender in this forum.

Other than that, how about more information and the proper one. It’s completely uninteresting that you got Bitdefender (at this point at least) what is interesting is CPU, GPU, RAM, OS, DriverVersions, Graphic settings.

Your question is a bit like… my car doesn’t start… it’s red! But as it is thousands of kilometers away you got to guess-fix it. - If you catch my drift.

Thanks for your replies everyone,
derekrb25017 Right now, it’s anything whatsoever that is amazingly slow, operations, selection, scaling, zooming…rendering was fine the last time I attempted it, but nothing seems to be working at any reasonable speed right now.

I was thinking of Bitdefender as more analogous to “my car is regularly maintained by a professional mechanic”, or my computer is at the very least less likely to have a virus, and the drivers are all up to date.

I’m happy to relocate this thread to a more appropriate location, can anyone tell me how to do that?

In the mean time:

“do you have force-enabled antialiasing for OpenGL?”, I’m not sure arexma, which most likely means no, how do I do that?

The specs of my system are:

OS: Windows 7 Home Premium 64bit
CPU: Core i7 3770 (3.4GHz)
Graphics Card: GTX670
RAM: 16GB
HDD: 1TB
DVDRW
21.5" LG TFT Monitor

If I should put other information here, or there are links here or elsewhere I should be refering to please lets me know, I’m a novice and what is obvious to others isn’t to me yet.

Thanks Everyone,
Tim

Amazingly unspectacular specs… nothing exotic.

It’s in the nvidia control panel. You can force-enable it in the 3d settings.

Anyways. I suggest you download Process Explorer which replaces windows task manager and is much more powerful and meant for analytics.

Configure it to show CPU, HDD, RAM and other loads that might be important and sort the processes per load.
Start Blender and do your stuff and check if any process peaks and uses all the resources. It’s a first step to identifying the problem.

Thanks very much arexma:-)

I’ll apply these changes and post the results and any questions here.

Tim

Hi ravel, another question is are you have problems even with the default cube scene.
If I have 10 objects with subsurf 8 in textured mode my system also slows down.
Try also set factory defaults.

Cheers, mib.

Thanks mib,

I’ll test that out too.

Below are snips of my GPU settings, there are multiple anti-aliasing settings and the MODE seems to be “application controlled”, so I think these are the right settings. Blender wasn’t in the program settings list when I opened it, so maybe that was the whole problem, I added it and hopefully the problem will disappear on restart.

Are the settings correct, or do you need more information?



Tim

Hi,
is this with the 313.96 NVidia Drivers? With my system I discovered the same problems and solved it by switching back to the 310.90 driver.

Pehaloc

Thank you Penhaloc I’ll give that a try. :slight_smile:

Ummm it was just the one file, everything works just file %^&* array modifier uses so much computing.

It works!!