Blender runs painfully slow on my laptop. Help me please :(


(TheEmissary) #1

I have a Compaq Presario with a 1000 Mhz AMD processor, 256MB RAM, and a sucky S3 Twister-K 16MB graphics card. Now, when I run blender there is an 8 second delay between keystroke and action. Even when the scene contains only a cube.

I thought it’s because of my graphics card but then I heard from another guy that he runs blender with no problems on an old 266 mhz laptop with ATI rage. Obviously ATI rag pro is better than my card but is there nothing I can do to make blender run normally on my laptop?

I’m new here so I’m sorry if this isn’t the right forum.


(Dani) #2

eeerggg… that’s a rare chip! :smiley:
Most graphic problems with blender can be solved by updating your drivers. There might also be some exotic function you must disactivate in the display panel. You might as well try to put your graphic acceleration to “none”, who knows? :-?

Ciao
Dani


(TheEmissary) #3

Thanks. I’ll try that.

Any more suggestions?


(theeth) #4

Did you check if other applications running in the background are not slowing down your comp? Other than that, the problem would mostly be graphic card related since Blender’s interface is all Open GL.

Martin


(TheEmissary) #5

No I don’t think any other program is slowing it down.

the problem would mostly be graphic card related since Blender’s interface is all Open GL

If that’s the problem is there any way to fix it?


(theeth) #6

make sure that the drivers you are using (for your 3D card) are Open GL compliant. If not, then you could just turn off hardware acceleration and the cpu will take the burden.

Martin


(TheEmissary) #7

How do I turn off harware acceleration?


(theeth) #8

Control Panel -> Display Settings -> Settings -> Advanced

Martin


(TheEmissary) #9

I lowered the level of hardware acceleration and it worked.

Thanks for the help!!!


(endi) #10

Maybe this will help:
-turn off mouse shadow (win2000)
-set display to 16 bit (on my vaio laptop with s3 card, blender is very slow with 32 bit display)