Blender says graphics card is not supported and won't run on Linux

When I try to run Blender I get the following message:

$ blender
/run/user/1000/snap.blender/gvfs/ non-existent directory
Read prefs: /home/quinn/.config/blender/2.81/config/userpref.blend
Received X11 Error:
	error code:   2
	request code: 151
	minor code:   34
	error text:   BadValue (integer parameter out of range for operation)
Received X11 Error:
	error code:   2
	request code: 151
	minor code:   34
	error text:   BadValue (integer parameter out of range for operation)
Received X11 Error:
	error code:   2
	request code: 151
	minor code:   34
	error text:   BadValue (integer parameter out of range for operation)
Received X11 Error:
	error code:   2
	request code: 151
	minor code:   34
	error text:   BadValue (integer parameter out of range for operation)
Received X11 Error:
	error code:   2
	request code: 151
	minor code:   34
	error text:   BadValue (integer parameter out of range for operation)
Received X11 Error:
	error code:   2
	request code: 151
	minor code:   34
	error text:   BadValue (integer parameter out of range for operation)
Received X11 Error:
	error code:   2
	request code: 151
	minor code:   34
	error text:   BadValue (integer parameter out of range for operation)
Error! Unsupported graphics card or driver.
A graphics card and driver with support for OpenGL 3.3 or higher is required.
The program will now close.

Blender 2.81 worked just a few days ago. I am using Zorin OS (a Linux distribution based on Ubuntu). My graphics card is GeForce GTX 970. I got the following information about my graphics card:

$ lspci -vnn | grep VGA -A 12
06:00.0 VGA compatible controller [0300]: NVIDIA Corporation GM204 [GeForce GTX 970] [10de:13c2] (rev a1) (prog-if 00 [VGA controller])
	Subsystem: ZOTAC International (MCO) Ltd. GM204 [GeForce GTX 970] [19da:1366]
	Physical Slot: 4
	Flags: bus master, fast devsel, latency 0, IRQ 37, NUMA node 0
	Memory at fa000000 (32-bit, non-prefetchable) [size=16M]
	Memory at e0000000 (64-bit, prefetchable) [size=256M]
	Memory at f0000000 (64-bit, prefetchable) [size=32M]
	I/O ports at e000 [size=128]
	[virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
	Capabilities: <access denied>
	Kernel driver in use: nvidia
	Kernel modules: nvidiafb, nouveau

I found websites that describe how to update Nvidia drivers on Linux but nothing has worked. This thread Blender 2.8 supported cards says Blender 2.8 works with GeForce 200 and newer.

How can I get Blender working? Is GeForce GTX 970 no longer supported?

The 970 is as supported as any other modern card.

It’s likely that the drivers for the card aren’t setup correctly. Could be a conflict with the nouveau driver, which should have been blacklisted if you installed the drivers manually.
Check if nvidia-smi works.

I am on ubuntu 18.04 LTS and this page has helped me to install the current driver. Maybe that helps.

Please, share here the result of each of the following orders:
lspci | grep -iE 'vga|3D'

cat /proc/driver/nvidia/version

sudo lshw -c video

You install the following package:
sudo apt-get install mesa-utils

Then share the output of this order:
glxinfo | grep "OpenGL renderer"

Blender had a software engine. I don’t know if they keept it or not. they used to have the main executable, and also a software gl executable. Might have moved this into a commandline switch.

$ lspci | grep -iE 'vga|3D'
06:00.0 VGA compatible controller: NVIDIA Corporation GM204 [GeForce GTX 970] (rev a1)
$ cat /proc/driver/nvidia/version
NVRM version: NVIDIA UNIX x86_64 Kernel Module  430.64  Sun Oct 27 11:26:12 UTC 2019
GCC version:  gcc version 7.5.0 (Ubuntu 7.5.0-3ubuntu1~18.04) 
$ sudo lshw -c video
  *-display                 
       description: VGA compatible controller
       product: GM204 [GeForce GTX 970]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: [email protected]:06:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:37 memory:fa000000-faffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:e000(size=128) memory:c0000-dffff
$ glxinfo | grep "OpenGL renderer"
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  151 (GLX)
  Minor opcode of failed request:  24 (X_GLXCreateNewContext)
  Value in failed request:  0x0
  Serial number of failed request:  41
  Current serial number in output stream:  42

Thanks for the response. I followed the instructions on that page then rebooted. Now Blender runs fine.

1 Like

How did you install nvidia driver before? From .run file?