Blender scene slower on what should be a better computer


(AbdoMagdy) #1

I have tried the attached scene on two different computers. It is not a complex scene; it just has two objects with view subdivision level of 3.

I am using the official release of Blender 2.79 on both machines.

The first computer is the new MacBook Pro 15-inch with the following specs:
OS: macOS Sierra
CPU: Quad Core 2.8 GHz Intel Core i7
RAM: 16 GB 2133 MHz LPDDR3
GPU: Radeon Pro 555 2048 MB
Intel HD Graphics 630 1536 MB

The second computer, is my desktop PC that has the following specs:
OS: CentOS 7
CPU: Intel i7-4790k Quad Core 4.0 GHz
RAM: 32 GB 1600 MHz DDR3
GPU: Gigabyte Nvidia GTX 770 OC 2GB

When I open the scene on desktop PC, the viewport navigation is fine, but selecting objects is slow. It takes a couple of seconds to update the selection. The only way to get around this, is to lower the subdivision level to 1. On the MacBook Pro, this doesn’t happen.

Initially, I though it might be the GPU, since Blender is using both GPUs for OpenCL computing. However, when I disabled one of them, the scene is still really responsive, with no issues at all.

Could it be the newer CPU on the MacBook Pro, the faster RAM, or just a mere difference between OpenCL and CUDA?

Attachments

bike_tyre_test.blend (1.48 MB)


(English is not my native language) #2

Hi.
Have you installed the nvidia proprietary drivers on your PC?
If not, you install nvidia drivers. I do not know how it is done in your distro. Distributions often have driver manager or package manager from which drivers can be installed.
Please share the result of the following commands from the terminal:

lspci | grep -iE 'vga|3D'
cat /proc/driver/nvidia/version

By the way, selection methods have more to do with OpenGL than with OpenCL. This depends a lot on the graphics driver you are using. You have several selection methods available in Blender User preferences > System > Selection. If you are using intel iGPU (or nvidia Nouveau driver) instead of nvidia and proprietary drivers, you should try for example with “OpenGL Occlusion Queries”, and maybe then also marking the option below “OpenGL Depth Picking”. Anyway you should try to use nvidia card with proprietary drivers.


(AbdoMagdy) #3

I already have the proprietary drivers installed. CentOS has a repository that packages the drivers, so users can install it easily.

I am away from that computer at the moment, but I will share the output of the commands as soon as I am back.

I know I have the 384.59 version of the driver.


(English is not my native language) #4

Yes, you may have packages installed but for some reason drivers modules have not been loaded. Second command I asked will inform us about that (I hope)


(AbdoMagdy) #5

Hi YAFU… I don’t think the problem is in the driver. I have Windows on the same machine, and it also has the same issue, despite having the NVIDIA driver installed.

However, here is output of the commands you sent me:

<i>lspci | grep -iE 'vga|3D'</i>

01:00.0 VGA compatible controller: NVIDIA Corporation GK104 [GeForce GTX 770] (rev a1)
<i>cat /proc/driver/nvidia/version</i>

NVRM version: NVIDIA UNIX x86_64 Kernel Module  384.59  Wed Jul 19 23:53:34 PDT 2017
GCC version:  gcc version 4.8.5 20150623 (Red Hat 4.8.5-11) (GCC)

It is also worth mentioning that I tried enabling “OpenGl Depth Picking” (without “OpenGL Occlusion Queries”) and it seems to have fixed the problem. I am not sure why I need it on my PC but not on the MacBook Pro, but for the time being, it seems to be doing the trick.


(English is not my native language) #6

Yes, different selection methods and that option can improve performance. But it is strange that with nvidia proprietary drivers selection works very slowly as you mention. I have had similar problems on Linux but using OpenSource driver, but never with nvidia proprietary drivers.
Good to know that that option in the configuration has been useful.


(AbdoMagdy) #7

Yea… It is really strange for me that the selection is that slow with the proprietary drivers… My only guess is it might be because the GPU itself is old, but I will have to wait after I change it, to see if that is the issue. Should do that soon, hopefully