Blender screen capture issue.

Hello there,
I’m using Camtasia to record Blender tutorials but since Blender 2.66 I am having some issues. When I try to take the recorded video in the Blender sequencer I’m getting some weird box pattern at the 3D viewport. This must be happening because of the new 3D viwport transparency feature (the one that lets you have transparent toolbar and properties when hitting N or T). Everything in the 3D viewport looks like an alpha part I can’t even see the mouse cursor!
Is there any way to disable the viewport transparency when recording? I’ve tried to tweak it in the user preferences but couldn’t find a way. I could also try to make Blender ignore the 3D viewport transparency when importing the recorded video in the sequencer but I also fail at doing so. Any help is welcome!
Thanks in advance!

2 things:

  1. Maybe try turning the alpha feature off when recording the tutorial test, and see what happens with it there
  2. Maybe try using the default theme for the tutorial and switch back when done

Or

It could be the codec you are recording with - I am using camstudio and their lossless codec, and maybe this coudl be where your problem is. I had a heck of a time getting mine to work until Derek showed me how to fix it.

Thanks for the quick reply Craig!
How do I turn it off? If I’m not mistaken you had to turn it on to make it work, I’m not getting transparent toolbar when working in Blender but it still looks weird when capturing. I’m using the Techsmith (default) codec in Camtasia when recording and never had any issues before Blender 2.66.

So it is causing a problem with using the default values in Blender? When I first opened Blender, the transparency wasn’t on until I enabled it in user prefs under Region Overlap in the system tab.

Yep, it does. The region overlap is unchecked. I’ve uploaded a test avi jpeg video (29Mb). It looks even more weird when Blender renders the sequence. Take a look: http://dfiles.eu/files/q9ugbchp4

I can’t download the link - any way you can put it up on youtube as private or vimeo instead?

Youtube link: http://www.youtube.com/watch?v=terblqwuz9M

Except for the mouse cursor being a block, I’m not seeing much else wrong. I would suggest setting the theme to the default theme and trying that, since I noticed in some of the dark themes that not all my text drew correctly sometimes.

That’s the problem, the theme you see in the video is actually the default theme. Check the outliner at the top right corner. Crazy huh?

looks like the Back to Black theme… crazy

That said, maybe get camstudio and try that, I haven’t had this kind of problem so far

True! Looks like Back to Black. Thanks for your time Graig!

EDIT: Looks like this only happens when trying to edit the captured video in 2.66. Could this be a bug?