blender screencast

Whenever I try and record the Blender screen with the screencast, (Alt/F3), the video always turns out choppy and too fast. I know to go to the preference tab and set the FPS, but nothing seems to work. Can anyone tell me what settings to use in the preference window and in the rendering settings to slow the recording down and not make it look choppy? Thanks.

It could be your system can’t handle the throughput. What application are you using to record?

I’m using Blender. It has its own internal recorder. You set the frames in the preferences panel. What is a good FPS to use in this preference panel? And what about the wait timer?