Blender script missing


I’ve lost all my scripts and when redownloading blender, the script folder doesn’t appear in anymore.
After searching a bit, it appears that windows users faced simillar issues which was fixed arround 2.47. The problem is that I’m on Mac (no installer) using 2.49b.
So, how can I get thoese scripts again ?

Thanks in advance.

If it was/is your work you should use ‘find’ (UNIX) to look for your files!

Or if there is a ‘make availabel deleted files’ on your (for) Mac try that … otherwise you did not know
that own work MUST be on two different physical locations in case the normal version is destroyed (deleted by …) (or so)!

I probably badly explained myself. The missing scripts are the standards ones from Blender like create a Torus or export UVs… ect.
A “Scripts” folder is supposed to be in the .Blender directory, isn’t it ?
Well, I don’t have that folder “Scripts” even after downloading a fresh New copy of Blender!

Have you tried downloading blender from one of the other mirror sites
Have you turned on hidden files (scripts folder is in hidden folder location) ?
In the user preferences do you have the scripts location pointing to an incorrect location ?
Have you tried setting the scripts directory manually in the user preferences ?
Have you tried deleting your .B.blend file that is used for your default statrtup file?
Have you tried resetting blender to factory defaults from the file menu ?

I tried to download new Blender versions three times (each from a different mirror but also the light version without ffmpeg).

The “Scripts” folder you see here is one that I created in order to use my different exporters.


$ls -a
.			Python-license.txt	copyright.txt
..			Scripts			plugins
.DS_Store		release_249.txt
BlenderQuickStart.pdf	blender.html

$cd Scripts/
$ls -a
..			bpydata
.DS_Store		bpymodules

In Blender, the Script’s path point to this created directory. And yes, I did try to bring back factory default which didn’t help.
I can see the exporters stated upper in Scripts/Exoprt and Scripts/Render but these are the only that I can found.
Nothing under Scipts/Mesh, Scripts/UV… ect…

Deleting that .B.blend may help! Where is that folder located ?
EDIT: found it and deleting it restarted factory default again. There was not any scripts available (even not the ones I had before).

So, I’m still blocked!
Is there a place from where I can download blender scripts ?

Well, digging more allowed me to find that hidden scripts folder. Its location is: