Blender Sequencer

Blender Sequencer is not rendering all the strips(only the first one, or the one where i place the pointer in the timeline is rendering) when I press the render animation button

The problem is that when it goes to the next strip it won’t render. If I drag the cursor in the timeline, it display the animation…

I have 9-10 strips

is it a bug ? or is somthing i miss ?

here is the video capture of my problem…

Did you set the correct Start and EndFrame and -Do Sequence- to active in the Anim Panel of the Render Buttons?


yes it renders all the 3000 frames, but only the first strip is rendered, the others are black

here is the video capture of my problem…

Your YouTube link is reporting an error – no playback.

You say you can scrub the strips OK (drag pointer in Timeline) – how about playback using ALT+A, does that work OK also? What types of files are your source materials? What kind of output has been specified.? This kind of info might help the troubleshooting.

If at all possible, try to provide a .blend, so others can see if the problem is reproducible.

the youtube link is working now…

here is the blend file

here is a avi sample

when I press alt + A is not working

This behaver is somthing like…i render only channel 1…but if I set to channel 0 it shoul render all the channels…

I can’t use the .blend without also having the source files for the strips, plus the Plugin you seem to be using in the second half of the edit. Nothing for the Sequencer to work on.

That is curious. What is the blending mode of the third strip? Can you render just that strip, by itself? - this is the plugin, but it doesn’t have to do with this plugin. If I remove this plugin, my problem will persist

I can’t just put all the video file that I have… the folder is over 300mb :smiley:

The strange thing is that if I render(f12) as a image…is working just fine…and if is not working, i can hit the refresh button from image editor and it works

so…I think this is a bug, and I should find another tool to edit video :(((

r: yes if I render a strip by itself is working, and I bet if I insert the same strip many times is working
PapaSmurf - the blend mode is replace…but it doens’t have to do with it

If I click the strip 3 and I render animation from there, is working. The big problem is when it should go to the next strip, it fails to render.

There where it fails to render, if I render a image instate of animation is workin…

this is drive me nuts :expressionless:

So can you make a “stripped down” version of the file that shows the problem (no plug-in), then pack it all into a zip archive? Raw video usually compresses well. If you need a spot to park the archive I can give you a url to a good free server, will take individual files up to 100Mb.

It will be right nigh impossible to troubleshoot this without having a file in hand that displays the problem. I’m doubtful it’s a bug, but the best way to tell is to try and reproduce it on another computer setup.

What format are you rendering the animation to?
What OS and Blender version are you using?

I’m curious because I get weird stuff like that happening when I try rendering to AVI on my Windows machine at home, but not on my Linux machine or the Windows machine at work. (As a workaround, I ended up mixing strips to a series of PNG files. Then I loaded them in as a single strip to make the AVI.)

Could it be forcing the output file to exceed 2gb?

Can’t do a great deal with what you’ve provided, but there does seem to be something odd about how the strips you’ve laid in are acting. Using the example video source (00191.avi) I also ran into some issues like you described both when using your .blend and when placing the vid in a strip in a new .blend file.

As far as I can tell your problem is related to the compression codec your camera (or whatever) uses – there have been reports of problems using compressed video as source for VSE strips, it’s just not all that reliable.

I opened the source vid in Virtual Dub and output a raw (uncompressed) .avi dub that when placed in the VSE shows none of the problems the compressed source did. Though it means using much larger source files, I recommend you make raw .avi versions of your material and use those for your VSE editing – it should resolve a host of issues.

I’m on Windows, the original format is MST, but blender doesn’t read mst :(. I will try to compress in avi raw format

Thank you

update… it’s working and the mts, but I have the same problem, and this are original files
I’ve put 2 mts strips on seq. and the same problem…

What is the original format mst’s or mts’s. mts is mpeg2? I’ve never heard of mst? Do you mean mts?

If it’s mts, blender reads them via FFmpeg and I haven’t as yet had any issues.

If it’s an mts then you could use DGIndex to get a d2v file, create an avs file and load into AVISynth via VirtualDub convert your footage to png image sequence and import into blender?

Add the sound from the mp2 that DGIndex creates.


blender read this file
I think if I import the video as img would work…but to import video as images ??? will take at least one year to import :)))

I will try to work with blender 2.5 …i don’t know if it works the sequencer >:), but I will try

blender 2.5 is amazing much faster, more options, more intuitive, but for now…animation render is not working :smiley: