Blender "skips" frames

please, throwing “my linux works” comments around, doesn’t help at all when the question is about windows.

.b

I have 64 bit Vista on my laptop and there aren’t any problems with blender at all

maybe it’s your driver settings, do you have SLI on or, max # frames render ahead active, Vysnc, Anti aliasing? if so, try turning them off or making a custom config for blender with factory driver settings

and to add a bit of editorial, Linux is so much better for Blender stuff