Blender Slow on MacBook Pro 13" HD4000 Mountain Lion

Hi Guys,
I wonder why Blender so slow on my MacBook Pro 13" HD4000 Mountain Lion,
I tried to install Windows 7, it works very well, but I dont want to buy Windows 7,
I try Lubuntu, it runs well too,
i dont mind to use lubuntu, but since theres another programs i use on mac osx,
so it seem troublesome to switch os.

Thanks!

It is a little hard to tell with such limited information but here is my best guess.

I have a Macbook Pro with an nvidia 9400M (ie. a good deal older than yours) which runs fine until I have a very high poly mesh (like while scuplting) at which point it slows to a crawl. I think this is because the Mac can only use 256MB RAM on the GPU. Windows and Linux can use 512MB RAM with the same hardware. Also, as a fact, the Mac versions of the drivers are never as efficient as the Windows ones.

Thanks for the reply Jono,
The interface is very slow,e.g. like dragging on the timeline is slow, more tabs more slow, strangely it is faster on lubuntu via vmware (of course not as fast as the lubuntu i installed normally on HD), i really dont get it??
and actually it happen on other 3d software, i tried installed houdini apprentice, the interface is slow too (and yeah, its normal in lubuntu version), but why the games i installed are fast (e.g. doom 3),
I think the problem is the OS (I have Mountain Lion installed), come on Apple… really… its very stupid problem,
its a good machine, what a waste…
Anyway, i will stay with Lubuntu for Blender, and use Mac Osx for music project or playing games…
Cheers!

Hey Guys,
Miraculously fixed!! After I try to install custom themes, “MOYO” by GLG, now everything smooth!!
I wish I knew what’s the problem, anyway everything is good now :slight_smile:

Thanks for the theme GLG !!

I’ve been wondering why the UI is slow with any mac with an Intel HD 4000 GPU. Saw this post and also tried the MOYO theme and to my surprise… no lag in the value sliders etc. I did a little testing and found out that if you deselect all the “Shaded” options for the UI elements it stops the lagging.

User preferences -> Themes -> User interface -> deselect all “Shaded” checkboxes.

Maybe a bug in the graphics driver/blender when drawing opengl shading/gradients? But happy that found a solution for the lagging. :slight_smile:

J

Yeah, after You said that, i tried to turn on the shade and everything becoming slow, i think thats one of the reason, anyway I’m happy too now, no need to change and reboot OS :smiley:

Hi, nice find, it work also on linux with my laptop onboard chip(Intel Corporation Mobile GM965/GL960).

Cheers, mib.
EDIT: Could you do tests with ctrl + alt + t Draw window?
It is only a small difference but feels less laggy, hm.

That’s totally weird!

The only difference in the code is an extra call providing colors for the drawing arrays, 2 lines:

glEnableClientState(GL_COLOR_ARRAY);
glColorPointer(4, GL_UNSIGNED_BYTE, 0, col_array);

People who can compile, remove it from source/blender/editors/interface/interface_widgets.c
Interesting to hear if that matters.

Reliable redraw timer is in Blender. CTRL+ALT+T
So you can check the real differences on similar UI layouts.

BTW: for intel hardware, you should try to disable Triple Buffer, try one of the others (overlap flip would do fine).
Preferences System tab.

Atleast with my setup (MacMIni 2012 i7 2.6GHz, OS X, IntelHD 4000, Blender 2.65a) Triple Buffer works best. If i use other draw methods (even though the values below are similar) the menus are laggy. Below are the average Draw Windows speeds I got:

  1. Factory Settings (Window Draw Method: Auto) = 132.48 ms
  2. Factory Settings (Window Draw Method: Triple Buffer) = 132.37 ms
  3. All Theme UI “Shaded” boxes deselected (Window Draw Method: Triple Buffer) = 12.02ms

Somehow the default “Shaded” options seem to slow down the window drawing more than tenfold with an Intel HD 4000 GPU.

For reference I did the same tests on an MacMini Early 2009 (Core2Duo 2.0Ghz, Geforce 9400M) and there was practically no speed difference with the UI settings. I suppose they are consistent because of the Nvidia GPU, although its an old one.

  1. = 31.02 ms
  2. = 31.10 ms
  3. = 30.98 ms

My laptop is MacBook Pro 13inch ivybridge 8gb ram HD4000.
I think the problem is on macosx opengl driver, apple have their own opengl driver.
I tested with Sintel Lite rig’s file (texture on, turn on layer 1 and 11),
macosx without shaded UI (overlap) have an average 16-17fps,
Lubuntu with normal UI (overlap) have an average 17-18fps
Fedora with normal UI (overlap) have an average 16-17fps (but maybe it depends on mesa driver version)
scrubbing timeline on Linux feel more smooth,
macosx with “VBOs” on will be faster, linux with “VBOs” on will quit blender.
when I select the controllers on the rig’s facial, it have lag time on Linux, but macosx doesn’t have any lag time, and maybe it depends on the setting on linux also.