Blender, slow start-up

Hi,

Not sure if this is the right forum section to post this issue but since today it takes a long time to start blender om my pc. When it finally opens and i try to save the start-up file it also takes a very long time for no apparent reason.

please have a look at the video i screen captured. http://www.filedropper.com/2017-02-2416-55-59-3

Can anyone tell how to fix this problem?

Does nobody has an idea what is causing this issue and more important how to solve it? I installed a second instance of Blender from .zip to a portable harddrive and it does exact the same thing. Another ‘strange’ thing is that some of the files from the recent file menu load immediately, but some other files also displayed in that menu takes a few minutes before its loaded into blender.

thanx

Hi, please add your system specs, Blender version, Driver and so forth.
There was reports about slow down / lagging in Windows 10 because of broken Nvidia driver update.
You can try start Blender from command shell with --factory-startup to get clean start without external addons for example.

Cheers, mib

Thanks for your answer, My system specs:

Windows 10 pro
Intel® Core™ Quad CPU Q9300 @ 2.50GHz 2.50 GHz

x64 Processor

DirectX runtime-version 11.00

NVIDIA Quadro FX 1700

Version 342.01

Blender 2.78b-windows64 (.zip)

Can you tell how to start Blender from command shell with --factory-startup?

Hi, all from memory:
Windows key + R
Type cmd > Enter key
Then follow manual:

https://docs.blender.org/manual/en/dev/render/workflows/command_line.html#ms-windows

You can copy the path to blender.exe from Windows Explorer.
Then > cd > paste path with mouse right click context menu.
It is really hard to explain for somebody never work with it.

Cheers, mib

Hi, i managed to open blender from cmd line with –factory-startup but it makes no difference. Loading the start-up file takes minutes and everything what has to do with accessing/change files/folders within blender also takes several minutes before its being processed.

Or perhaps i did that wrong, this is what the console is showing me;

C:\Users\hp2>cd C:\blender

C:\blender>blender --factory-reset
Read new prefs: C:\Users\hp2\AppData\Roaming\Blender Foundation\Blender\2.78\config\userpref.blend
AL lib: (EE) UpdateDeviceParams: Failed to set 48000hz, got 44100hz instead
found bundled python: C:\blender\2.78\python
unknown argument, loading as file: --factory-reset
Error: Cannot read file 'C:\blender\--factory-reset': No such file or directory
... opened default scene instead; saving will write to C:\blender\--factory-reset
Traceback (most recent call last):
  File "C:\blender\2.78\scripts\modules\bpy_types.py", line 665, in draw_ls
    def draw_ls(self, context):
KeyboardInterrupt


location: <unknown location>:-1


location: <unknown location>:-1

OK, there was a report in bugtracker about slow file browser but user was not helpful so was closed.

https://developer.blender.org/T50601

You can add your information + sample file there or open new report.
You need an account but only email and username necessary.

Cheers, mib

it looks like you have a bad addon. disable all your addons and try again. forget the command prompt, just go to the hidden directory:

C:\Users\%Name%\AppData\Roaming\Blender Foundation\

and delete or move the the “Blender” folder. this has all your settings, so if you spent time setting up colors or shortkeys, then be careful with it. im betting it will have addons in there too.

1 Like

thank you for your reply. I accessed the folder you pointed out by typing %appdata% in the command line. Then i moved the complete Blender folder to the desktop. When opening Blender again all my user preferences are indeed gone but the same problems still occur :frowning:

Hi, please report this as “Bug” as I wrote in post 7.
You get help from Blender developer if they can reproduce the error.

Cheers, mib

hi,

you also wrote You can add your information + sample file there or open new report. And thats what I did. Its a bit confusing one can still add information to a closed report. But I will open a new report now.

thx

a not properly removed SD-card was causing these problems. All fine now.

Hi Ray,

Can you explain what was the problem and how you fixed it? I am experiencing exactly the same issue… startup takes a few minutes on a fresh install of Blender…

Thanks!
Oalf

I just experienced the exact same problem. It took Blender a minute to come up and loading and saving was practically impossible. But not just Blender, the whole Win10 was in a weird shape.

The tip with the SD card was exactly right - there was still one in one of the slots. I guess the problem is related to some operating system file system/access problems. Thanks!

I know this thread is ancient, but since it pops up when searching for slow blender start-up:

had the same problem,

in my case it was a network drive, where the connected drive/pc/server wasn’t available, so the drive
was dispalyed with that red cross.

simply disconnecting the drive solved the problem.

Sometimes it is the update checking for many of the more popular add-ons…if the access to the reference site is slow it will slow start-up to a crawl… Hover over the console window on start-up and you will see what I refer to. Best advise…keep updates current and or if available, turn off the update checker in the preferences…

I wanted to chime in here in case others have the slow startup issue as well. I watched my console window, and the only thing that happened during my slow load was that the userprefs.blend loading message sat on the screen for a long time. up to ten minutes. Then blender would finally load. The problem started a couple of days ago for me. It also happened if I did Command line rendering. The userprefs.blend file would take forever, then suddenly everything would work again.

I found this thread while looking for solutions. I have no SD card readers, and I had no network drives connected. However, I had a blank DVD in my DVD drive, because I was working on another project, and forgot I left it in there. So I ejected the DVD.

Weirdest thing, but after ejecting the disc (with blender closed,) All of windows locked up, and would not respond anymore. I had to do a hard reboot. I should mention that when this problem started yesterday, I rebooted then as well, but it did not solve the issue. Blender remained slow until after removing the blank DVD.

But after removing the DVD and rebooting, blender loaded immediately, and my command line render worked again. as AeroLynx suggested, there appears to be some kind of file access error when certain types of removable drives are connected and Blender is running, to the point it can cause Windows to lock up.

So, if you are having issues, Disconnect removable drives temporarily, make sure all network drives are disconnected or properly connected (no red ‘x’ on the network drive!) and make sure nothing is in the CD/DVD drive.