Blender stopped working

Okay, so I am new to Blender. I have some experience with Maya, but I wanted to test the waters and see what I could do with Blender. So yesterday I downloaded Blender to find that it did not work–all I got was a blank white screen where the GUI should be. I thought perhaps it was my graphics drivers–which, admittedly, where really out of date–so I spent a while updating them and a few other things that I knew needed updates as well. After that I tested Blender again and it worked. I called it a night and this morning I was messing around with it, figuring out the editing tools and interface, and it worked great. I had no problems with lag or anything, so I figured that the drivers were the problem.

However later today I tried to open Blender again and I was greeted with the problem I had last night.
(link to screenshot of screen)

I have no idea what could have caused this problem. I was thinking it might be the drivers again somehow, but I also have Maya on this laptop and it runs fine. I also uninstalled and reinstalled Blender to make sure that the original file had not become corrupted somehow, just in case.

I’ve noticed that if I hover over certain areas of the blank white screen my pointer changes accordingly to what it would if the screen displayed properly. For instance, in the areas where I know I could adjust the size of the windows, my pointer changes to scaling arrow.

This is all especially strange since as I said it was just working this morning. If someone could provide any help at all, that would be incredible!! Thank you!

There are no technical details in your post: OS (kind of MS?) version, PC or video card make, driver versions, Blender version etc;
check if this might be the same issue