Blender stops responding when interacting with sliders

Blender consistently hangs on me whenever I use modifiers like subdivision, using the color wheel to change material color, and using the sliders to change scale/location/rotation etc. It doesn’t start when I start a new project but it happens after a short while, even on projects where the poly count isn’t high (only around 9k faces) Blender stops responding and hangs for a few seconds before resuming. Anything I can check to see if something is slowing down blender? I don’t think it’s my specs, it hasn’t happened before a few weeks ago.

Specs: i5 4590, GTX 970, 24GB ram, 1.5TB HDD storage

Hi.
You mention which is your OS and the version of Blender. Does the problem also occurred in previous version of Blender?. Have you tried renaming the user settings folder (Blender factory settings)?

O sorry sorry, I’m running Blender 2.79 on Win10 64bit. And I haven’t tried renaming the user settings folder, what should I rename it to?

https://docs.blender.org/manual/ja/dev/getting_started/installing/configuration/directories.html

This I ask is in case you had chosen to copy previous configurations from Blender 2.78 or earlier version within 2.79. You can “Load Factory Settings” from the Blender menu, but that can be dangerous if you save some settings, because it will overwrite your USER folder settings and you will lose user settings. So, it is better to rename your “2.79” USER folder (for example “2.79-original”, open Blender 2.79 and do the tests to see if you still have that problem. To restore original settings, first close Blender, a new “2.79” folder may have been created. Delete that new “2.79” folder if it was created, and renaming again “2.79-original” to 2.79.

All this makes sense if the first time you opened Blender 2.79 you chose to copy settings from Blender 2.78 or previous version.

Thank you! When I upgraded to 2.79, I did copy my settings over from 2.78. I’ll follow your instructions and let you know my tomorrow if the hanging problem persists or not. Thank you again for your assistance! :smiley:

Hihi o/

After a few days of messing around with Blender default settings, the freezing and hanging is still there. It only happens when I’ve been working in Blender for more than a few hours and the length that it freezes increases based on how long I’ve been working on any project. It doesn’t freeze if I add a subsurf modifier or turn on auto smoothing. It only freezes when I change the values like subsurf level, what angle I want autosmoothing to take effect, or when I open the color wheel and change the color of a material. And it doesn’t freeze consistently. It’ll freeze once and then it’ll be fine for a few minutes and then it’ll freeze again and it just repeats.

I am seeing this behavior as well. Especially with material previews and making changes to materials. I think is has something to with the materials compiling. Sometimes I have noticed it takes a while for the material to regenerate it then lags the computer.

I often get crashes if my viewport is in rendered mode and I am adjusting a slider or colorramp handle. I am on Win8.1 64-bit with Blender 2.79, (though the same issue was there in 2.78 as well).

I think that’s a different problem than other people are having with lag and slowness in 2.79. Your problem has been reported before and it was not clear exactly how to replicate the problem. This is supposedly solved in master now:
https://developer.blender.org/T51416

Edit:
Now that I think it better, people having the lag and slowness problem in 2.79 should also try blender from master/buildbot just in case it was related. Anyway the problem of Crash was present in all OS. This new lag and slowness problem apparently does not happen on Linux.

I’m seeing the same problem with a fresh installation of Blender 2.78. I’m using a new laptop Alienware 15, win 10 pro, i7-7700HQ 2.8GHz, 16GB Ram, GeForce GTX 1070 8GB video Ram. Even moving objects grinds Blender to a halt.