Blender suddenly really slow...

So I just built a new computer. It is (arguably) much better than my old computer. I’ve been running Blender 2.55 on my old computer for a long time, not really any problems. Lemme tell you about my old computer:

Win7 64-bit
ATI Radeon HD5350 (512 GB, only 1)
Phenom II quad-core 3.2 GHz
300GB 7200 RPM HDD

Then I decide to build a new computer:

Win7 64-bit
2 ATI Radeon HD5850 (1GB each, running in CrossFire)
Phenom II 6-core 3.2 GHz
64GB SSD (where Blender is installed, along with all my blender projects)
300GB Velociraptor HDD

Now, all of a sudden, Blender takes FOREVER to go into edit-mode, to bake physics, etc. Real-time editing seems to be just fine. No lag at all. But any time I change a setting on my physics properties, it takes a LOOOONG time to respond after I type the number and press “enter”. Lots of “program not responding” and then it responds if I wait 5 minutes.

The main scene that I’m talking about has about ~1 million polys (and cloth physics), but it is similarly slow (not as bad) with my scene that had 1300 polys (no cloth, but has smoke physics).

I’ve gotten the latest video drivers… twice.

This is true with the standard build from, and with the OpenMP MMX optimized build from MiikaH.


…running Fallout 3 and Crysis on maxed out setting with no problems, BTW.

Still no ideas? Still having the same problem with the new 2.56 trunk build…