Blender switches from GPU tu CPU everytime I start a render

Hey guys :slight_smile:
As I said in the title Blender switches from GPU tu CPU everytime I start a render.
I set my render device to GPU, I start the render, it renders in GPU and automatically switches the device to CPU.
I must have changed something since it wasn’t doing this this morning.
and it does it even in a new file.

When I start a render in CPU, it doesn’t switch back to GPU though.

I tried deactivating all the add-on I activated But it didn’t do the trick

I have Blender 2.71 running on windows 7 (64 bits)
GPU : Geforce GTX 650 Ti
CPU : i7 4770k
RAM : 16 GB

If you need more informations, just ask.

it renders in GPU and automatically switches the device to CPU.
What doe you mean it switches ? Does it render some with the gpu and then changes to the cpu or does it not render with the gpu, only with the cpu

Have you set the gpu as the render device in the user preferences and in the render panel. What other render settings have you set (Feature Set ? Open Shading Language ? etc). As its tooltip says OSL is cpu rendering only

thanks for the quick answer!

In the render panel, every time I render something selecting the GPU, it renders it well on the gpu but the devices switches to CPU (and my next render will be on the CPU if I don’t change it manually everytime)

My GPU is set both in the user preferences and in the render panel and I didn’t change anything but the samples (so Feature set : Supported, OSL : unchecked)

I can post a screenshot of the whole render panel if it’s more simple for you

Edit : Here it is :


Edit 2 :
Well looks like it renders only on CPU actually, it automatically switches to the CPU in the render panel before starting the render

Edit 3 :
Okay, I think the problem comes from my graphic card, i’ll try and update the drivers.
I tried rebooting my computer and it worked fine… For a while and then it started to do it again.