Blender takes 2 minutes to open then crashes if i use Cycles

First it takes a minute showing this message in the console

Read prefs: C:\Users\thinsoldier\AppData\Roaming\Blender Foundation\Blender\2.91\config\userpref.blend
WARN (bke.anim_sys): C:\b\buildbot-worker-windows\windows_291\blender.git\source\blender\blenkernel\intern\anim_sys.c:2926 BKE_animsys_eval_driver: invalid driver - cycles.preview_denoising_start_sample[0]

then it says it found python and then waits another minute

then it MAYBE will open the main Blender window and let me use it.

I updated to the latest nvidia studio drivers and now the problem happens in both 2.91 and 2.90. It did not used to happen in 2.90.

Now both 2.90 and 2.91 eventually open consistently but when I try to render with cycles they freeze and I have to force quit them.

I thought the “invalid driver” thing was about video card drivers or something. It was actually about a driver I had setup in Blender to link the viewport render samples with the start sample value under de-noising. Once I removed that from my startup scene file Blender no longer takes forever to open.

However, it still often crashes when I render with cycles.

Try disable “Preview Denoising” and “OptiX Denoising”.