Blender Texture Problem!

I made a model and imported it into blender, and exported it into a game.
This is what its supposed to look like:
http://i5.photobucket.com/albums/y165/SithDagger/tutorials/RPGReal.jpg

This is what it looks like ingame:
http://i5.photobucket.com/albums/y165/SithDagger/tutorials/Oook.jpg
http://i5.photobucket.com/albums/y165/SithDagger/tutorials/Ick.jpg
http://i5.photobucket.com/albums/y165/SithDagger/tutorials/Ack.jpg
http://i5.photobucket.com/albums/y165/SithDagger/tutorials/Gah.jpg

The texture is messing up, its on the inside surface of the mesh, not the outside where it should be…
As you can also see, the bolt should not be visible like that, as it should be encased by the model.

I’m not used to blender, this model was converted from a different format, as I use Milkshape.
Can anyone help me fix this?

What import did you use?
What export did you use?
Are all the normals pointing out?
What UV settings did you use?

You have a bad normals problem. you need to make sure you have all the normals pointing out. The best way to do this, is to go into edit mode, and under Editing(f9) and Mesh Tools 2 click the “draw normals” button. switch to “face select mode”, and then you can select the faces one by one, and set the normals (Ctrl + N, Ctrl + Shift + N)

Thank you my man :smiley:
that did it :smiley: