Blender to Renderman MOSAIC sss test

After 2 years of trying to reach the level of control that all of us Renderman junkies want, we have finally gotten to a very good spot with WhiteRabbits python script MOSAIC.

I decided that on a whim to try to see if the SSS in Blender was linked to the RSL shader that is included with MOSAIC, and lo and behold it is. So for the next 24 hours I tried different looks and levels of SSS, raytraced or shadow mapped. Today I got on a skin kick and have been working on making a decent skin material with low render times. Not bad considering 2 years ago we couldn’t do this with the scripts available to us to export to RIB and render.

http://picasaweb.google.com/animate1978/BtoR/photo#5227031082182859842http://lh5.ggpht.com/animate1978/SIolE0NvXEI/AAAAAAAAAFE/CYtpzu1-oVo/brat_pixie_sss_sm_001.jpghttp://lh5.ggpht.com/animate1978/SIolE0NvXEI/AAAAAAAAAFE/CYtpzu1-oVo/brat_pixie_sss_sm_001.jpg?imgmax=512

For more info on this go to http://www.blendertorenderman.blogspot.com/

We are working on developing more media for this project, to get people to try it. The ease of use is awesome and quite easy to learn as well.
http://picasaweb.google.com/animate1978/BtoR/photo#5227031082182859842

Wow! Great to see a nice detailed tutorial on using Mosaic. I’ll give this a look after I have some mo’ coffee. Cheers.

Direct link to LATEST Mosaic script (needed for tut.)
http://ribmosaic.cvs.sourceforge.net/checkout/ribmosaic/mosaic/mosaic.py?revision=1.39

Nice! Though at first glance the script seems a bit complex for the likes of me.

A few quick tests make it seem like Pixie renders faster than Internal, but just hitting ‘Render Current Frame/Passes’ renders without SSS – how do I enable translation of SSS to the renderer?

Don’t let the complexity fool ya, its possible too do a good bit without knowing what everything does :wink: As far as SSS you can enable and control it in Blender’s material settings just like the internal renderer (if your running the CVS version). Also I should mention because of a bug in Blender’s 2.46 Python API the token hook for the SSS “front” does not do anything so it has to be adjusted manually. Also you’ll need to play around with “IOR” and “Scale” since they behave a little different then Blender’s :wink:
If your running a raytraced renderer all the soft shadow settings should work automatically too.

At the moment many of the more basic light, material and world settings work automatically, but I’m currently working on getting almost all of them working “out-of-the-box” with MOSAIC’s built in shaders :slight_smile:

I’ll make sure I have the CVS version and will play with the IOR and Scale, maybe it was rendering SSS but with the wrong settings – and at a ridiculously high speed!

I’m looking forward to working with MOSAIC, steady on and thanks for your hard work!

Here’s my attempt. I don’t think I got the caustics right, and the shadow map seems wrong, too.In the command window, it says: ERROR: Map “F1Suzanne.em” is not a valid shadow map, use RiMakeShadow.

Subsurface scattering seems to work, though.:slight_smile:
I’ve uploaded the blend, too, if anyone spots where I went wrong, please let me know.

I also should mention how awesome the usability of this script is. The ability to scroll the menus and expand/collapse tabs is fantastic, I wish more Blender Python scripts had this feature.

Attachments



fatfinger:
I had to make several tweaks to your RenderMan setup to make it work properly:

  1. Added “Lamp” to group so caustic pass can properly use it as camera position.
  2. Removed the “Group Select” filter in the shadow map dialog so it see all objects.
  3. Removed the “Group Select” filter in the environment map dialog so it sees all objects.
  4. Enabled “Use Shaders” for the environment map so all objects use shaders in reflection.
  5. Repositioned light slightly to center on objects (shadows were so long they didn’t show).
  6. Since Lamp used a group filter the bumpy Suzanne’s had no shadow, so SSS wasn’t working. Once SSS worked I readjusted the “Scale” to 1.0.

A couple of things to note:

  1. The current shaders don’t offer much control over tweaking the blending of the occlusion data (something I’m working on). This is why the occlusion is so dark.
  2. The SSS “Front” control is currently not linked to the shaders. This is because of a bug in 2.46 but is currently fixed in SVN, I’ll correct this in MOSAIC when the next Blender comes out :wink:

WHiTeRaBBiT