Blender to Unity Loss of detail on textures


I exported my object files to Unity and noticed a loss in texture detail

I was informed that changing the texture import setting from 1024 in Unity would help and it did but not as much as I’d like is there an option when exporting from Blender I can change to improve how the object looks in Unity?

(I’m new to 3D modelling so any help would be appreciated) :slight_smile:

Not sure if this belongs heres cause its a texture problem but I thought it was perhaps more a compatiblilty problem and therefore a technical issue.



Did you try changing your texture type to “GUI”? Also try changing the Format to “Truecolor”/

Have you considered the fact that Unity’s filtering code might be different?

Does Unity contain any filter settings? You might want to check that if it does.

For future reference, unity only accepts texture sizes that is a power of two, 256, 512, 1024 etc. Other size forces it to be downscaled to the closest lower value. 1023 would become 512.