Blender to Unreal Animation Popping

Hey crew,

I’ve been dealing with a year long headache that “pops” up every time I think I’ve solved it. When I export fbx files for Unreal I get a horrible pop in my animation. It is very unpredictable when it will happen, but it happens often. I’m using a spline rig and going through the NLA strip process. I just cannot figure out what is wrong.

I have a folder that contains an unreal project with the skeleton and animation already imported, the fbx files I exported, the blender file, and screenshots of all my export and import settings.
Link is here:

Any help would be crazy appreciated and prevent me from wanting to smash my head through the wall.

Some things you could try are (haven’t checked files) animate at 30 fps, set simplify to 0, importing using Preserve Local Transforms ticked.

Pretty sure I’m in 30 fps (have that set under the render tab). Simplify and preserving local transforms sounded like great ideas, but alas the problem still remains.
I tried exporting turning off force start/end frames as well as simplify and the same popping appears. Thanks for the suggestions though. If you do get a chance to look at the files it would be helpful to know if you’re seeing the same popping.

Just added keyframes at the end (47) and used my export settings. I do not see any popping now.

Attachments (621 KB)

Amazing!! Could you share your process and export settings with me? For instance did you keyframe everything that was already animated on both armatures, or did you keyframe everything? Also, what units are you using in your blend file?

Thank you so much!!!