Blender to Unreal, Not really sure what is happening here.

Hello everyone,

I’m new to both the forum and Unreal. I seem to be having an issue bringing exported FBXs from Blender into Unreal. I’m not sure if this is a vertex weight issue, or a bone rotation issue, but in Unreal my mesh doesn’t deform the same as it does in Blender. I’ve done all I can think of, and corrections for possible issues I’ve found in various forums, and nothing seems to help. I’ve limited bone influences, normalized vertices, checked all my FBX export settings, still the problem persists.

As I said, I’m new to Unreal. I’m still working through the basics. So, I know there is probably something I’m missing. That being said, I’m very comfortable with Blender and have been using Unity for years. When I import the FBX into Unity, it works just fine. But, I don’t want to use Unity for this project. I’m really interested in learning Unreal. It looks like it is far more suitable for my needs.

Since it will probably come up, I can use Max. Though, I don’t own a copy, because, well…I’m poor. Also, I’ve used both Max and Blender for a while and I prefer Blender. Just a personal preference. I’ve touched Maya once, but have no real experience with it, nor do I own a copy, so it is of no help.

I’ll post some screenshots of what is happening and if I can figure out how to post the .blend I’ll post that too.

Thanks for any help in advance!

robbie_5_RunNoGun_Idle.blend (1.66 MB)

It’s a scaling issue, you should apply scale for the rig and the mesh, then go into the graph editor for the rig and select all bones, then type “location” in the magnifying glass search, and scale (press y to constrain to vertical movement) up by 11.361.

Also in order for it to loop properly you should export the whole loop, not loop-1, and make sure the first and last frames are the same.

You are now my most favorite person on the planet. Thank you so very much. This has been driving me nut for, well, longer than it probably should have been. Where did the 11.361 come from? I’m assuming at some point I must have scaled the armature at some point, thus causing this problem. Lesson learned I suppose. I will pay more attention in the future. But, if I do this again in the future, I’d like to know where that number came from so I can fix it. Again, I don’t think I can thank you enough.

it would seem I spoke too soon. This solution works if I only concern myself with the run animation. As soon as I add another animation, say an idle animation, the issue reappears. I did as said. I applied scale to both the mesh and the armature, then rescaled the location on the graph editor and that worked for the run cycle. But, that messed up my “Idle” animation. Instead of sitting on the ground he stood up. I thought ok that’s fine i’ll just repose him. As soon as I touch the idle in blender the run no longer works correctly in Unreal.

So, I did some further testing and it seems that no sooner do I create a second animation in the action editor does the run animation stop working in Unreal.

Here is my process. With the mesh and armature’s scales applied and graph editor adjusted, I can export an FBX to Unreal and the animation runs just fine. I go back into Blender, into the action editor, and created a new animation. I then reposed my model into his idle position, save the animation in the action editor with the “F” button, and export another FBX. When I import that FBX into Unreal, I get that same weirdly distorted mesh. If i go back into Blender and delete the idle animation and reexport, the FBX goes back to working correctly in Unreal.

I’m seriously at a loss. This is driving me crazy. Thanks again for any help.

The scale is shown under Transform in Scale. You will need to do the scaling in the graph editor for each animation. Also the idle animation shouldn’t affect the run animation. Maybe you’re using scale keyframes, in that case you should either delete them or insert a scale 1 keyframe for the run animation.

You can upload your new .blend too.

robbie_7_2_RunNoGun.blend (1.67 MB)

Here is the latest .blend. I tried scaling the graphs for both animations, run cycle is fine. If I scale the graph for the idle the whole armature sort of explodes, if that’s the right way to put it.

So, it seems If I export one FBX with only the run animation, armature and mesh, and a separate FBX with only the idle animation and the armature, no mesh, everything works fine. Is this the way I’m supposed to do it? Oh well, I’m just glad it works.

Thanks again for your help.

Yes, usually you export the mesh with the armature without animations for the skeletal mesh, then have a separate .fbx for each animation. This makes organizing things easier and makes the reimporting process better too (reimporting a single animation is faster than importing a huge file with all animations).

I have a script for exporting animations here: