Blender <-> UVLayout bridge

WOw if your a Noob t Python you did very well, perhaps you have coding skills. But you did really well. I just wanted more settings. PS why have you made 2 panels now its better 2 kep them in 1. Its confusing when they are divide into 2.
I dont get why you want such a big send button. Its break with the style of bleneder. looks weird.

PS what happens now in your version when nothing is selected? In the old version everything got exported. I added code so only visible items are exported, so hidden an layers OFF wont be exported.

The apply modifiers is also important! You get errors when you import your UVs back. I made a extra option for that part.

PS we should merge the code, though your GUI looks way different. BUt mine is compact cause it only shows OSX possiblities, on windows it will show more.

I dont think this panel will work in a pie menu. I hardly use pie menus and i dont think the num menu can be done. Thats why i added a pop window instead.

He Titus, do you have this same issue? On OSX it seems sometimes meshes are imported with wrong z-scaling. I noticed it before but dont know why this happens. All scale is applied and all. Sometimes after a couple test export it fixes it self suddenly???You can easily replicate it by adding a standard cylinder and sphere and export these.

PS you shoudl change the coordinates in the export to Z and Y. It was weird to see the model from the bottom each time UVlayout opens

Attachments



Its actually a UVlayout issue or perhaps this is normal behavior. I notice when SUBD setting is used with loading. Using Poly they load normally.

First image is Poly, second is SUBD mode

Attachments



I mean l’m a new user on blenderartists.org. and in this case if you a new user of the forum you have to wait forum moderators approval of your post until you reach ten posts :wink:

ahhh okay. Well you did great job looking into this. I always liked UVlayout but didnt use it cause of the hustle all the time with OBJs etc. I model for fun, sometimes its for little job.

Now with this bridge its super easy. I’ll post mine on Github

rombout is your bridge going to be posted on Github?

Sorry bkjernisted, i finally got the extra commands working but bumped into to some other stuff now. Something weird… When in local view nothing is exported yet when i do a manual obj export in local view it is exported. This is probably cause the mesh is beeing copied and the copied mesh isnt selected (which is needed for the export).

When i git that part working i run into a new problem. In single mode in local view i got it working but now i need to add the option again to use all selected. So im thinking to drop the local view and just pass a warning that this is not possible.

I had some other commands working and when i just wanted to make a screengrab i cleaned my code a bit. Now it doesnt work any more … hahahaha it was options to do quick packing and automatic dropping and relaxing. So i need to work on that part a bit more

Thanks rombout.

Okay long fiddling and error and pulling hairs from my skull… But i got something working again.
Though for me on OSX some items are a bit buggy and some are kind of useless. But im able to send all load options now as well as automated packing - save - return to blender. I also have some other codes which work but here the window crashes, perhaps the Windows users will have more luck.

Im going to clean the thing up and i will drop it on gitHub. Hopefully i get all done tonight.

Ive also managed to get a check for local view. This is something special and cant be used for now. It will return a warning, just like other options which could return a error.

Below is a screengrab with the auto packing, i then need to manually send back the file. This is usefull if you want to check it first.

If your BOLD, than you use pack and save-return. Only for the brave :wink:

I perhaps need to finetune the timing a bit. Problem is when there is something wrong with the time a certain file is written, i end in a loop and all goes beserk :slight_smile:

Attachments


I got 2 more ideas i need to add;

  1. Is saving the windows path to a file, otherwise you need to set this each time you restart Blender.

  2. Adding custom export path. For me on OSX the program is a bit unstable sometimes im left with the unwrap and and nothing is saved. With custom path you can easily find back the location and save. Also open the tmp file is something happened.

There is a file generated *.keep you can change his to *.obj and then still open the file. In case of possible lost connection.

I got point 2 done, and point 1 i already added to save OSX layout version to *.ini file just need to dd windows path and windwos path

Below is addon pref panel with settings you can put

Attachments


Can this problem I had in blender 2.79 be straightened out with blender or uvlayout. It is a hole in an anvil I modeled but the uv mapping around the hole is all messed up.

Attachments


Ive setup a github for my version, its has also the extra option for auto-packing and auto-pack and save return.
There some ore action possible but for me OSX they result in closing the open window. Seems very unstable.

The custom path seems to work properly now. When something does happen and you can send back the model this custom path is handy to still be able to import and transfer the file. Or for acces temp files created.

Do you support Linux ( Mint ) version?

I have problem, probably with paths and permisions, like this:

Where can I change path for template objects?

Hi there, there is no linux support , because i have no clue about linux and Osx. but you can check inside script. it’s :

path = “” + tempfile.gettempdir()
path = ‘/’.join(path.split(’\’))

at script beginning.

and there is commented part of the code about OS:
#—OS—
if platform == “darwin”:
l = os.listdir(UVLayoutPath)
appName = (str(l).strip("[]")).strip("’")
uvlayout_proc = subprocess.Popen([UVLayoutPath + appName, ‘-plugin,’ + uvlb_mode + ‘,’ + uvlb_uv_mode, path + file_Name])
elif platform == “win32”:
uvlayout_proc = subprocess.Popen([UVLayoutPath + ‘uvlayout.exe’, ‘-plugin,’ + uvlb_mode + ‘,’ + uvlb_uv_mode, path + file_Name])

I hope it helps.
and also you could try rombout version from github.
Thank you

1 Like

I havent touched that part as well. BUt i can take a look at it. If he can show paths for linus i can add it.

I got a different addon which works on Linux, i can take a look at that if he still needs it. I didnt get a update on this thread??? I hate this new forum so much

I don’t know if I’m doing something wrong or if there’s an issue with this addon and Blender 2.79.6, but every time I try to send a model to UVLayout it complains that the mesh has issues and I should load it with “Clean” or “New” enabled. The issue is that both of those boxes are checked already because I haven’t done any UV mapping to the mesh at all in Blender as I prefer to do it all in UVLayout. No matter what options I turn off or on UVlayout continues to complain and not load my mesh.

This is using 0.6.2 of the plugin and the latest UVLayout.

Could you share an blender file please? or send it to me. Thank you.

Unfortunately it’s something for work and thus I cannot share it. I’ll try to duplicate the issue so that I have something I can send you.

Have you tried it with part of the model, perhaps this work.

PS what does the console give as errror?

Ok for those of us unfamiliar with "headud: or with 3DS max I am guessing that this script tries to imitate the functionality of this program.

http://www.uvlayout.com/index.php?option=com_frontpage&Itemid=1

I read the first post in this thread and looked at the screen shots and found myself asking. OK this is good but WHAT DOES IT DO?