Blender Viewport Blocky

Hey everyone, I just built a computer, and when I’m running Blender on it, the viewport looks a little jagged on how it displays everything. How can I make the lines crisper and cleaner?
My computer should be capable of displaying the picture better in Viewport mode.

Graphics Card: Nvidia GeForce 560ti
CPU: Intel i7

Thanks guys!

Hi, it would have been nice to see a screen shot, there are some settings to change.
First try to set Multi Sample in User Preferences > Window Draw Method, next is set your driver settings to antialiasing for blender. What OS and blender version you are using?

Cheers, mib.