Blender VSE: Super Slow Speed

I hope I’m posting in the right forums here. :stuck_out_tongue:

This is a technical issue in itself, so I figured it would be okay to post in here.

What my problem is that everytime I try to load the “scene/Alpha Overlay” effect into the VSE, Blender slows down to an unacceptable speed. So bad it takes at least five seconds to scroll along the timeline. I cannot complete it because it runs so darn slow. Here’s the weird bit though - I’ve been able to complete it at least twice in the past (on Blender 2.64), but now (Blender 2.66), for some reason, it’s too slow. Is it a glitch or scripting issue? I’ve got it running at a low resolution (100% with dimensions 640x480 and a framerate of 30), so there’s no reason why it should have to slow down like that. And nothing else in Blender is exceptionally slow - just that single effect in the VSE. IWhat the heck is going on? I’ve tried uninstalling and reinstalling. Nothing has worked thus far. This is absolutely devastating to my filmmaking career.

Please help.

Bug reports traditionally require computer sytem spec and OS. Then version of Blender (release number best) and perhaps an example .blend file. Also are you adding aneffect strip or changing the nature of a media strip?

Okay, I’m fairly certain I’ve got a 64-bit Windows 7 Toshiba laptop, with version 2.66 of blender. (How can I bring a .blend file on here?) I’m adding an effect strip.