Blender weird hotkey errors?

				Kind of hard to explain this but I was practising some modelling and all of a sudden my hotkeys no longer worked.

Pressing S for scale toggled on proportional editing and Ctrl Z no longer would undo. Also, I tried to save the file as “wtf” an it saved as “,yu.blend” So something is up with the keys in blender.

Restarting blender fixes the issue but after about 10 mins or so editing in edit mode and it hapens again.
I thought it might have been some custom hotkeys so I changed everything back to factory settings but it still happens

No clue whats going on.

While this is occurring in Blender, try bringing up another app (Notepad, etc.) and see if you can type normally in it. This issue could be your PC.

Hi Mike
Thanks, yeah I already tried that and in notepad the characters type normally.
It was like the whole keyboard had remapped itself randomly somehow.
When it happens again I will save another file from a>z and see how they have changed.

(Edit: Oh, I have 2 logins lol. I just logged in with this account instinctively. Didn’t actually know it existed! :smiley: )

Ok thats really weird I didn’t even get to edit mode that time. I think the sequence was something like: Delete Box, ShiftA add plane. Then try to scale and doesn’t work:

Here is what the a>z mapped to:
axje.uidchtnmbrl’poygk,qf;
abcdefghijklmnopqrstuvwxyz

Will try a reboot and a reinstall of blender.

Hmmmm, apparently this is the Dvorak keyboard layout.
If you go to Regional and Language Settings > Languages > Details
you can remove the Dvorak.

Apparently it was some sort of hotkey like Alt/Shift that initiated it.
I’ve removed it now. Hopefully this was the cure :smiley:

Sounds like it should be :slight_smile:

Where do you do that?
Is it within Blender, or is it with Gnome / KDE control panels?
I have a similar problem and I can’t find the path you mention…