Blender with Ubuntu - Very glitchy!

I have the newest stable version of Blender and Ubuntu 9.04 (Gnome desktop). When I load blender, it acts like I have Compiz enabled. It’s as if something is interfering with OpenGL. Of course, I turned Compiz off…that’s why I’m posting this. I tried it in OpenBox and it seemed to be just fine, but I’m not too keen on command line stuff like connecting to the internet, so I don’t like to use OpenBox. :spin: Anybody else have this problem? Thanks.

confirmed, including fuzzy windows (which is being worked on). To set your expectations, “latest stable” from graphicall, in light of Blender undergoing a complete rewrite, means that it does not crash immediately after you move the mouse. Anything it does after that point, up to and including the last thing it does just prior to crashing, is gravy. a gift. a miracle, as it were. Check back in 3 months. There is a general plan of functionality to be included back in, and bugs you can/should file. Check out the roadmap.