Blender won’t save

I’ve installed the newest version of Blender (2.45) via the windows installer. Everything works as I go through the tutorials, except that I cannot save anything. In the “Save As” dialogue, the “Save” button is not accessible and the text field where I should be able to enter a file name is highlighted red.
Similarly, the www.blender.org button on the upper window header above the 3D view window is highlighted red and does not act as a link.
In previous versions of Blender, this button is green
I’ve uninstalled and reinstalled several times and everything remains the same. I even installed older versions of Python to see if this would fix the problem, yet nothing changes.
Have I missed a step in installation? It doesn’t seem possible that such a problem is the result of my ATI video card.
Any resolutions? Is this a known problem?

Similarly, the www.blender.org button on the upper window header above the 3D view window is highlighted red and does not act as a link.
I don’t believe it is supposed to. It is just to show what version it is and where blender’s website is.

EDIT: I just discovered that clicking the little blender icon next to this shows the splash.

In previous versions of Blender, this button is green
I believe that it changes every version.

As for the save problem, I have no idea. Could you please post a screenshot?

Here is a link to a screenshot

http://home.comcast.net/~skeuomorph/blender_screen.jpg

Well, in the picture you have posted, You type the name where it says ‘test.blend’ and then hit enter, then either hit enter again, or click the Save As button.

I dont see anything highlighted in red, except the blender button.

You need the newest version of python, not older versions? You match the python with the Blender versions. But I think the auto install will also install the correct version of pythong…

I most not understand your question.

Hitting enter does nothing. Nothing is saved. The “Save As” button in the window is never active or clickable. When you type a file name such as “Test.blend” the text box is highlighted red. Red usually implying a warning or that something is amiss. Nevertheless, the program will not save a file, no matter what name is used or how many times “Enter” is pressed.

I also have the newest version of Python (2.5.1) but went ahead and installed 2.4.4 as well in case this is the problem. Python does not overwright previous versions if the default install directory is used. I have several programs that require older python versions, so i actually have four different versions.

Because of ArcGIS liscencing and the cost, upgrades to the core ArcGIS program are usually not accessible to private users, so I have to keep the Python version installed with the ArcGIS software.

None of the “Blender not saving” issues appear to be related to Python version. Is there a Blender specific python script or script package required for Blender to run correctly?

Now I feel like a complete moron. Nowhere in the documentation does it indicate that “Enter” should be hit twice while saving. Apparantly, i never tried. So I tried again and sure enough it finally saved.

Given that what was green in the most previous version I had, is now red in the newest version, I have assumed from the begining that there was something afoul with the installation: green vs. red = go vs stop = right vs wrong.

Given that I am an anthropologist and that colour choice is never random nor severed from meaning in every known culture on the planet, proffesional conditioning seems to have gotten the best of me.

Python only affects what scripts you can run. Many libraries Blender needs to run certain scripts are actually bundled with Blender. Blender should always work just by itself, python is only an extra that is recommended.

Okay, I am not sure what you mean about the file saving stuff so do this step by step:
GUI version:

  1. Open Blender
  2. Press File>Save As
  3. Click on the little arrow below the beige P on the left side.
  4. Click C:\Documents and Settings\Your Name\Desktop
  5. Click in the text box on the same level as the arrow button. (NOT the top text bar next to the P)
  6. Hit Backspace to clear the previous entry and type a name.
  7. Click somewhere (like the empty space in the file browser).
  8. Now click the beige Save As on the right side.
  9. The filebrowser will close. Now minimize Blender and look on your desktop. The file should be there.

Keyboard Version:

  1. Open Blender
  2. F2, click in text bar, Backspace, type a name
  3. Enter, Enter.

Just so you know, the errors in blender are shown by a popup at the cursor that say what is wrong and have a little warning icon next to it.

sorry. After you type the name in, you have to hit enter to enter the name into the field. Then enter again to save, or click the save as button.

You will find that will also be the same issure to input in fields in blender and even some other selection routines.

Althought I cant think of an example just now. But you will select something, and actually what happens is you have only deselected something. So you must select again.

Make sense?