Blender won't launch on dual proc. mac OSX.

Blender won’t launch on my mac. No errors or messages pop up.
Macine specs are - Dual 800mHz Power pC G4.
GE Force 2 MX video card 32mb vram
1.5 Gb SDram

OS- OSX vers. 10.3.9
Blender vers. 2.37 (tried 2.36 too)
I can’t find any topics here that seem to explain it and the vid card is supported.
Any help would be appreciated.

have you tried 16 bit [thousands of colors] color mode?

on a similar train of thought, what resolution are you running at?

Look at the consol app for any error messages. You probably need to lower the resolution of Bleder’s startup. It can cause a problem when it’s too high on a 32mb video card. Are you set past 1280x1024?

Thanks for your replies.
Screen res.- 1024x768
Colors- thousands
Vid card-tried 32mb but also 64 mb card(GEForce)

Console error message (thanks masterhoshi, I should have thought of this)

dyld: /Applications/blender-2.37a-OSX-10.3-powerpc/ can’t open library: /System/Library/Frameworks/Python.framework/Versions/2.3/Python (No such file or directory, errno = 2)

Presumably I need to download Python? Will look into this.

Thanks for the replies, I cracked it. Installed (updated?) Python 2.3 and put the python.frameworks folder as it should be according to the console error message . Everything seems to be working now. Didn’t really know what I was doing so I hope everything runs OK.

you had something severly screwed in the system. Python 2.3 is part of all 10.3 Os X.