Blender won't load .ps script. No faq shows how. Want .obj

I want to use one of the .obj importers for Blender.

I have the most recent stable release for Blender, and I downloaded the most recent python as well.

I put the .ps files in the bender plugins subdirectory.

When running Blender, I can click on the top left corner and choose Scripts. When I then try to select Add, that command hasn’t been added yet, it missing along with a few others in the scripts menu.

So how do I add a script?

I see several scripts for importing .obj files, and other scripts for exporting them again to .x files, so I want to try them.

Other programs, such as Milkshape, gmax, and basically every other program I’ve tried to do conversions with, can handle an .obj file that is 1 megabyte long, but not one that is 5 megabytes or more, no matter what plugins or options I try with them.

I’m hoping Blender can help with this.

You need to change it to a .py file (not .ps) and if by ‘most recent stable release for Blender’ you mean 2.37a then you need to use Python 2.3.5 (which is not the latest).

If you can’t find it in the Import menu after changing the extension click “Update Menus” at the top of the Scripts menu in the scripts window, and if that fails goto the Text Editor and navigate to the folder with “Open New”. Then with your mousecursor on the text hit Alt-P.

%<

The files were .py not ps… I made a typo.

Using Python version 2.3
‘import site’ failed; use -v for traceback
No installed Python found.
Only build-in modules are available. Some scripts may not run.
Continuing happily.

It knows what version of python I have, but detects not its installation. How strange.

Clicked on the link you posted, going to check it out now. Still worried about whether .obj importers have limits to the file size though.

Also, if so many people have problems with this, why don’t they make the installation easier? Or have the official site explain exactly how to get everything to work.


When I run the script I get

file length: 149291
found 0 smoothing groups.
unable to open referenced material file: “D:\Blender.blender\victoria.mtl”
obj import time: 5.38874382079

The file is far larger than 149291. Is that the problem? Could the script have a maximum limit?

Whats the largest .obj file anyone has ever imported, and what importer did you use? Which one is the best for this type of file?

Is that V3? Poser/Daz obj?

See the thread below:-

https://blenderartists.org/forum/viewtopic.php?t=55174

Nobody answered so far; try the 236 script and see how you get on. I have been using Blender 2.4a2 and Python 2.4.

I think the size of file is not the issue but that a Poser style wavefront object is slightly different to other wavefront objects ( I know, sounds mad).

Maybe someone will solve it in time for the upcoming release.

There are more Poser type questions in this forum, none of them seem to be adequately answered not sure why.

That’s not the version you have, that’s the version Blender uses internally.

As far as installation goes, if you use the python installer, it should create the PYTHONPATH variable, after that, depending on the os, it’s just a matter of rebooting/relogining in.

Martin