Blender won't run in Windows 10

When I load blender now all I get is the DOS window and it’s blank. That’s it. I tried it in 2.74, then upgraded to 2.75a and still no luck. Any ideas?

System specs: Win10 Home x64, Core i7 3.4 GHz, GeForce GT 640, 16GB RAM

Hi, there are sometimes problems with Intel integrated GPU, special older chips.
Check if orginal Intel driver is newer than your driver.
Please allways add system specs for tech support questions.
I have no problems to run Blender 2.75a on my i5 laptop with HD 4400 GPU and Windows 10.

Cheers, mib

Sorry I forgot about specs. I tried it and then went out for a couple hours and came back to find that eventually it did open, it must be just taking a very long time. This PC is not very old, just over a year and I’m not using an integrated GPU.

Win10 Home x64, Core i7 3.4 GHz, GeForce GT 640, 16GB RAM

So here’s something new. As I said it takes a long long time for blender to load, but once it does it also takes a long time to do anything for example I hit File > Open and it sat for a long time before doing anything then opened the User Preference and it just sat there saying “Not Responding” for a long time, like an hour.