Blender wont start.. A black screen is all I get

Hi everyone…

I wasnt sure if this is the right spot to post, so move thread if appropriate.

I recently upgraded my computer as I do a fair bit of digital painting, 2d animation and recently 3d with blender and zbrush…

Im running:
i7 920 CPU
6G DDR3 Ram
Gigabyte EX58 UD5 motherboard
Nvidia 1G GTS 250 (ASUS manufaturer)
all on Windows 7 Home Premium (64 bit)

The only software that is giving me issues is Blender. Ive tried both 2.49b and 2.5 (64bit and 32bit), tried it in compatibility mode, installed python 2.6.4, and on start up all i get is a black screen. Window that tells me that it ‘found python’ appears to indicate that everything is OK, however the main workspace is completely black…

On the 2.49b installation, when I start the blenderplayer icon it tells me that vcomp90.dll is missing. However on the normal blender icon on start up all I get is the black screen.

If anyone has had any similar issues, could I get some help finding a solution?
Ive have not been able to find too much information. Other links on this forum related to vcomp90.dll have not had a solution that has worked for me unfortunately…

Thanks in advance…

Hmmm… try to resize the blender window and move it. If the workspace is still black, try to update the drivers FROM THE ASUS PAGE. If you actually have the latest driver installed from asus, try the 195.62 driver from the nvidia page, and disable aero.

I know ASUS once a time produced decent graphics cards, but nowadays i tend to avoid asus for video cards… way too much problems with some software on these cards.

Hope it helps.

The only thing I can think of is upgrading your Nvidia drivers. Could be an issue with Windows 7 support of OpenGL.

You may wish to run a virus check on your system. For me I can run all version of Blender except for Version 2.50 . . . can’t complain as I love blender too much to speak negative about this program.

Thanks for the quick comments. There are a few things there I can try.

I didnt realise ASUS have there own drivers (I was using the latest nvidia driver … and will have to look for ‘aero’ to disable it).

I will also try the asus driver. Will keep you posted.

Thanks again

Have you tried installing the Visual Studio 2008 redistributable? There’s a link on the blender download page:

Thankyou again for all the helpful comments.

After trying the visual studio 2008 path, latest asus driver path… I turned off the Windows 7 Aero theme… Problem solved!!

Thanks for the help everyone…