Blender won't start up, at all

For some reason blender (any version from 2.35 to 2.41) will not start up on my machine.

I don’t even get to the splash screen, I just get a "The instruction at “0x00000000” referenced memory at “0x0000000”. The memonry could not be “read”.

Everything was running fine a few weeks ago. I’m running Win2k and have heaps and heaps of programs installed on this box.

It is the same error msg for all version of Blender.

Are there any dlls etc that Blender uses that another app would have killed?

Is there a list on the net showing the dependancies for windows Blender anywhere?

I tried deleting all previously used Python path variables etc - still no luck.

Anyone got any ideas?

Further this is the debug output I get:

D:\Blender241>blender -d
Blender V 2.41
argv[0] = blender
argv[1] = -d
Using Python version 2.4
Warning: could not determine argv[0] path
Color depth r 8 g 8 b 8
Aux buffers: 4


Registering scripts in Blender menus …

Getting menu data for scripts from file:


if they’re required blender wouldn’t even get that far and you’d get an error about the dll being missing

I’d bet your graphics driver is messed up. If you turn graphics acceleration all the way down, and reboot… does blender start?

if so, try reinstalling graphics drivers and such

Tried both turning off acceleration and downgrading my Nvidia drivers.

Still have the same problem.

I’m thinking it might be an error in creating an OpenGL context to render the screen to.

All other OpenGL apps seem to run fine.

I tried using the Window2000 default driver and the error came up with an actual location that couldn’t be read, rather than “0x000000”.

Maybe I’ll try downgrading further…

This is the error I get - any ideas what the number “47c” means (in decimal it is 1148)? It changes each time but the rest (ie the memory address) stays the same - it does change if I try to open a .blend file but not if I just try to open blender normally.

I’ve done a few tests etc and I feel it is nothing to do with Python but everything to do with acquiring an OpenGL context (or whatever Blender tries to do about that time)

EDIT: I also have a thread here