Blender2Cal3d - Help me!

Hi again!

I’m trying for 2 weeks to convert my Blender model to cal3d. I used all versions of blender2cal3d.py scripts I found (for Blender 2.42). But problems with skeleton (out of place) and animation persists…

Please, coud someone test it to me? --> http://fellowsheep.googlepages.com/lop_unique_sem_no_inf.blend (ignore textures).
I think that problem is in the centralization of the model, but I didn’t get fix it… Please, I need cues… It’s urgent!

Thanks,
Rossana

Got a few suggestions

Have you moved the armature object when you created the skeleton? That could be the “skeleton out of place” issue. Try make a new skeleton, without moving the armature.
Also remember to have a open 3D View when you export.

best regards

Oh! Yes, I moved armature to my object when I created it. We can’t do it, sure?

I will make a new skeleton, just centering the mesh object to adapt to it.

Thanks, thanks… :slight_smile:

Rossana

In most of the various Cal3D exporters you can read:

Rotation, translation, or stretching Blender objects is still quite buggy, so AVOID MOVING / ROTATING / RESIZE OBJECTS (either mesh or armature)!
Instead, edit the object (with tab), select all points / bones (with “a”), and move / rotate / resize them.

Maybe I’m repeating what was said, but the meshes and the armature must have the center in the same position, I suggest un-parenting everything, moving them all to the center, 0,0,0 alt-g, clearing rotation with alt-r and adjusting the centers.

I just noticed in 2.42a when you add a Armature, it got RotX 90.0, RotZ 90.0 as default in Global Transform properties. This could be a issue most peoble will miss to notice.

Btw what export script are you peoble using for Cal3D. I use the one from http://endercg.altervista.org/

Could be nice with a cleanup with all those different versions of the Cal3d export format. Took me some time to finally find a version that did work with blender 2.42a. And abit messy to report bugs, when the official cal3d exporter in the CVS seems broken and alot of peoble are using customized versions.

best regards

vanleth, I asked the author for the latest script before release, perhaps if the script is maintained externaly we should not include a version in Blenders release. since cal3d is not a realy standard format AFAIK.

True cambo, it will probably confuse more with a broken exporter in a release. Just sad with no official Cal3D exporter. Since it is being used by some smaller projects out there.

Hmmm… I think it explains why my cal3d model generated had its skeleton “lying” (rotated 90°). Ok, good cue.

Another doubt: I have a root bone, in which I extrude all the other bones. My root bone is the “head” of my model. So, I extrude from it the “body” and the two “upper arms” bones. From each these “uper arms” bones I extrude more one bone, I called them “lower arms” bones. With legs I did the same, extruding from “body” bone (or back bone). My cal3d .xsf file describes all them. But in cal3d miniviewer, the “lower” arms and legs don’t appear… Is it normal? There are limitatons in extruding bones?

The atached image shows the problem…

Best regards,
Rossana

I’ve seen the same, with disappearing bones in the miniviewer (shown with the s key), but still the animation plays fine. Could it be something with bones that have vertex assigned are the ones that don’t show up in the miniviewer? If so, i’ve seen it working ok once, but can’t remember what script it was.

What export script and miniviewer do you use fellowsheep? It would be best if we used the same for testing cal3d issues.

Cambo & Bookeater: About a the official cal3d, in this thread http://blenderartists.org/forum/showthread.php?t=77833 Bookeater would happy do the job, don’t see why that couldn’t be done, he gets my vote :slight_smile: Are you still interested in that bookeater?

best regards

I get a segfault whenever I try to export with animations :
http://emonville.com/3D/mei_cal3d.zip
Script is built in (the segfault happens no matter which version I use, but this is blender2cal3d_3), just alt+p and press e to test.

Using Blender 2.42a under Ubuntu Dapper

As always, anyone’s help is very much appreciated.

Yeah! :slight_smile: These tip solved all my problems! :smiley:

The script I’m using is one I get from a Soya’s users site (I don’t remember adress now, but Google is here ;)). Here it is --> http://fellowsheep.googlepages.com/blender2cal3d-dachary.py

The other scripts didn’t generate animations (they generated Action.xaf but in viewer model doesn’t move).

Very thanks for everybody that helped me!

See ya,
Rossana

Glad it worked I’ve had a lot of trouble with scripts and the c++ side of cal3d too but I still think cal3d is a good format.

About the interest for the script, I am the author of the last http://blenderartists.org/forum/showthread.php?t=77833 modification that, as mentioned by vanleth works with Blender 2.42 and 2.42a.
I am grateful for the mention.
About the possibility to finally make a definitive version I am a little busy and I have not the time to contact previous authors to join our efforts.
It would be great if any developer, interested, would help me to establish a project for future maintenance of the script.