blenderplayer read external .blends

On the blender website i read this
“With stand-alone games however, any data that is included inside the actual stand-alone executable is covered by the GPL. If this is a problem then you should set up the stand-alone player so it reads from external .blend files.”
can somebody please tell me how to get blenderplayer to do this?

Use the game actuator.

I think he means loading blends with blenderplayer:
Create a .bat file(or any other executable format like .exe with autiIT script) with the following line in it:
“blenderplayer -sc x y 32 pathToBlendFile”
and put the file where blenderplayer.exe file is located

-sc (screen mode: -w for window mode; -f for fullscreen mode)
x,y (if in window mode x,y position of the window in pixels
32 (color bits)
blenderplayer -w 100 100 32 myGame.blend

…there are alot mor options to the player just type blenderplayer/? in the cmd console

I’m on a mac I need to use shell.

Yeah, Moguri’s right - use the Game actuator and specify your external blend file.

Then the blend can’t be moved or it wont work. Is there any alternative that will allow me to place the blend in a folder with blenderplayer and move that folder around without it being disrupted?

You can use a relative path for the game actuator.

i had accept relative path checked but as soon as i moved the file (even though it was in the same player as the runtime) it didnt work.

Any other suggestions?

Try using two forward slashes in the game actuator to denote a relative path. For example //data.blend, if data.blend is supposed to be right next to your runtime.

It works in the bge but fails when I make a standalone and ends 2 seconds after I run it.

I found this tutorial, but for some reason when I tried to open the blend file with blenderplayer it still didn’t work. The icon came to the bottom of the screen as if it were going to open then it immediatley quit. Could somebody please tell me why this is happening?

If you run the blenderplayer (with your blend file) from the terminal, do you get any error messages?
Do you have python 3.2 installed?

I just installed python 3.2 and no, I don’t get any error messages the blenderplayer just crashes on startup.

please help

Hey, are you using Blender 2.58? The most recent version has a problem with the BlenderPlayer crashing (with blend files in general, not just when reading external files). Is it crashing on using the BlenderPlayer to run a file? If so, then you might want to try a Cucumber build from

I am, no wonder it kept crashing. Thanks for the link.

None of the builds on this site are able to make standalones. Whenever I click “save as runtime” with one of these builds nothing happens, has anyone successfully tested these?

Just tried a Cucumber build from Graphicall - here’s a link to the build I tried. It worked for me, but it was a simple scene with just the default cube moving forward. Are you sure it was a Cucumber build?

I’m running OSX. Got any builds that might work for that?