Blender's disappearing tooltip text

Does anyone know for what reason/under what condition the tooltip text disappears within Blender? I would be merrily working away and need to look up the function of a button - only to find that the tooltip text has disappeared on all buttons. It does not seem as if closing and re-opening Blender helps either.

I think restarting the OS (Windoze in my case) does the trick, but that is a nuisance.

I’m sure I am the only one experiencing this problem - as I know of others who have had it happening to them too.

Did you disable it in the user preferences? (drag the top header bar down to see them) in the View & Controls tag there is a “Tool Tips” button.

No, I did not. It just seems to happen haphazardly. I would be using it - and the next moment when I try to use it, it’s gone. And later it would be back. I have not been able to determine under which conditions it happens.

It does happen sometimes. I’ve found that I simply needed to slow down my mouse movement. If a tooltip fails to show, simply move the mousepointer away and re-enter the control’s space and pause the mouse. Also note that there are some things in Blender that do not have tooltips.

Also, you can find tooltip delay settings in the Preferences window.

(I can’t imagine that rebooting your computer is in any way part of the solution.)

It’s happend to me too in certain files; they just turn themselves off and I haven’t found out why.


Just like Fligh says - and I cannot turn them back on again in a controlled manner. It’s just a mild nuisance, nothing critical.

I’m having the same problem. Any info or help would be most appreciated!

Sorry Loner30, I have also not yet found a solution to this one :frowning:

I noticed that my tooltips started to disappear in Blender as well. For ages I couldn’t pinpoint what was causing it, until now.

This might not be the same cause for everyone else, but it is for me.

I keep winamp running (who doesn’t like music whilst doing 3D?)… and I keep it active either in shade mode or minimised.

The simple act of having Winamp active was cancelling out Blender’s Tooltips.

In order to fix the problem, you have to go into Winamp’s Preferences > Modern Skins > General Tab > Misc Settings > Set “Enable Tooltips” to OFF

This should stop Winamp interfering with Blender’s Tooltips. :wink: