Blender's single click selection has an area of influence, can I disable that?

Hey guys, I have a bit of an issue with Blender. It’s pretty hard to describe so I’ve included pictures. Basically Blender tries to help me select vertices, objects, edges etc… and I don’t want it to do that. So here is my cylinder, I’m clicking outside the object (my click is that little white cross)… nothing happens


Then as I move in closer, I can click again and Blender selects the vertex for me. Anyway I can stop this behaviour? Thanks in advance!


EDIT: Sorry for the triple post but I can’t seem to format the pictures or text correctly.

I’m having the same thing happen and it’s really frustrating. I am accidentally selecting edges or vertices that I have no intention of selecting. I don’t see any replies to this post so I am adding to it.

Please, does anyone know how to turn this off or reduce the area of influence to prevent this? Here is my example, I didn’t click (imo) anywhere near the mesh and yet it is selecting and edge. I do not have proportional editing on, and I have check in the manual and preferences for something to turn this off, or reduce it and can’t find anything.

Thanks for any replies.

Starting to think this is just one of those “quirks” with Blender that you have to live with. If no one has an answer or reply, I can only assume this is how it is for everyone and they just double tap “A” instead of clicking “off” the mesh to deselect.

Still think it is a bad behavior, and would actually consider this a bug if I were in a beta test with this happening. Clicking a half inch away from a mesh should not select anything.

Hi, I don’t think this can be disabled. I’m not sure why this is problematic in the first place ?

@Punker3D yes, hitting A clears selection. I think I understand : clicking on empty areas deselects in Maya, is that what you are expecting ?

Basically yes, my workflow I often would click “off mesh” to deselect, rotate view and then click select on mesh to continue working. I can train myself to double tap “A”, but it still doesn’t make any sense to me that clicking “near” a mesh, not “on” a mesh is causing a vertex or edge to be selected. There is clearly an exaggerated “influence” on the mouse cursor. Just wanted to know if there was a setting I was missing to reduce the pixel influence or something. Thanks for you reply, appreciate it!

@Punker3D Theres no way, but yeah there should be one.

1 Like

@Debuk, exactly what I’m talking about. So I’m not crazy (debatable) and does seem odd that it can’t be changed. I beta test for another software and this would have come up as a repeatable bug for me. However it is not a big issue, just need to pay attention to use double “A” tap. Thanks for your reply and link!

PS: I just tested the circle select, I thought maybe that influence was bleeding over, so I reduced the circle to the smallest value, then went back to normal select. No go, just thought I’d give it a try.

The double-tap thing is new in 2.80+, I personally changed it back to a simple toggle. So if there’s anything selected, hitting A will clear selection. I advise you to try it. You have to disable the “double A” hotkey and change the “A” hotkey to “toggle”, if my memory serves well.

1 Like

@Hadriscus Thank you! I much more prefer the single “A” tap for toggling back and forth as well. I will look at changing my hot key back.

Thanks for replying all, much appreciated! I really love blender, just a fairly steep learning curve. Purchased over $1k in addons and training, so I’m in for the long haul lol.

Wow ! you’re serious. Best of luck to you. The most valuable advice I can give concerning Blender is to keep oneself open to its peculiarities; some of them are really well thought-out (…and others a bit less).

It is certainly desirable that the hotspot size for click-selection is made adjustable, hopefully this gets implemented one day. Comparing with Maya though, I guess the big difference that does contribute to UX frustration is the lack of preselection highlighting in Blender. Perhaps it’s not so much of a problem for mice (though it still is a nuisance), but for tablets it’s a big deal. Seeing in advance what you’ll get if you click is a boon.

@Stan_Pancakes that would be nice (pre-select highlight) and I have yet to really dig in with sculpting via tablet. I find the hot key (just tried switching back to single “A” toggle, there were too many and got confused) mapping a bit overwhelming. I tried to setup my mouse and failed. Thought, I’ll just forget about my tablet for now.

@Hadriscus I should mention, I also purchased several asset libraries for work, which is probably the bulk of purchases, but too many addons to count heh heh.
I can’t seem to figure out how to change (which one?) the “dbl A” to just “A”. A bit esoteric from what I am used to. Thought it would be just one option…nope! :laughing:

Blenders shortcut system is a bit of an overkill. Its sensitive to where the mouse is hovering and the current context, so quite often “all of them” might be the right answer.

1 Like

It is one option if you’re using the Blender keymap, it’s in User Preferences, Keymap, Preferences collapsible panel (“Select All Toggles”). But it may not be available if you’re using the Industry keymap. In which case, you’ll need to expand the binding for the ‘A’ key and switch Action there from ‘Select’ to ‘Toggle’.
And yeah, as Debuk says, in that case that would need to be done to all of those mappings individually.


Like others have said the keymaps are specific to modes, so if you want to change the select/deselect behaviour across all of Blender, you’ll need to change them all. (Surely they could be merged to some extent, I don’t see a situation where I’d need a different hotkey depending on whether I’m working on a curve or a mesh.)

btw I have never seen some of those symbols next to the hotkey letters, that’s weird… Specifically the butterfly looking character and the one resembling a downward slope (?). Are those OS-specific or language-specific ?


@Debuk and @Stan_Pancakes thanks again for your replies and info, I really do appreciate it! I don’t want to to highjack the OP’s question as I have already started to deviate from the original question. So, I’m going to try and figure this out from both of your posts and then if I’m still stuck google and check manual.

Thanks again all!


@Hadriscus oh boy, I knew I would get outed eventually! Yes, OS Specific. I’m on a MacPro heh heh. I have a PC laptop and dual boot OS on my MacPro desktop for Win 10, but I learned everything on Mac’s decades ago (yup, i’m old). For some things, I am forced to use Win 10, but prefer macOS. I have run into quite a few issues with addon developers never testing on macOS and some still don’t work and that’s when I use my laptop or dual boot.

Those used to show up as the keyboard hints in the bottom bar in all OS versions of Blender, which was really confusing for me as they don’t exist on Windows. Thankfully @Harley fixed them by making them OS specific.